error applying config changes - Salt UnicodeDecodeError

  • hello,


    the topic was opened 1-2 times her but wihout resolution (besides reinstalling, but I dont feel like that).


    so when I want to apply a chang ein the webGUI (I tried changing a cron job and deleting a shared folder) I get an error.




    I read somewhere to do apt-get update & upgrade becouse the guy had an unfinished pachage.

    true : I have that too.


    Code
    bart@openmediavault:~# sudo apt-get upgrade
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Calculating upgrade... Done
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    1 not fully installed or removed.
    After this operation, 0 B of additional disk space will be used.
    Do you want to continue? [Y/n] y

    but that doesnt go. problem with (as far as I can see) python and some uft-thing. not linux-y or computer-y enough to know what do do now. :)

    see apt get error in attachment

    apt-geterror.txt



    my system information is in attachmentsystemlog.txt

  • thank you for the swift reply, but.....


    Execute omv-salt stage run setup. Hopefully thsi will fix the issue.

    ..... unfortunately not

    following error comes up



  • Is this an answer to your question?


  • Is this an answer to your question?


    Partly. I wanted to know which language you've selected during the installation, e.g. geman, english, french, ...

  • okay... solved this myself :saint:


    after reading and google'ling it came from an error in /var/cache/salt/minion/roots/mtime_map


    so, I made a backup of that file


    cp /var/cache/salt/minion/roots/mtime_map /var/cache/salt/minion/roots/mtime_map-OLD


    and emptied the mtime_map file (with nano and just pressed ctrl+K). It was a guess, but I had a backup :)


    then re-ran apt-get upgrade and all went fine 8o

  • speeskeek

    Added the Label resolved
  • speeskeek

    Changed the title of the thread from “error applying config changes” to “error applying config changes - Salt UnicodeDecodeError”.
  • Can you point me to the information you found? I do not see any connection between the problem mentioned above and /var/cache/salt/minion/roots/mtime_map, maybe the website will give me some more information.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!