FTP will not enable on OMV 6

  • I have installed OMV 6. Everything appears to be fine but when I try to enable the FTP Service I get a '500 Internal Server Error'.

    Thanks.

  • Agricola

    Added the Label OMV 6.x (alpha)
  • I installed OMV 5 and have the same error message.


    Here is a log I hope can help to detect the cause:

    I don't know if there are any problem, but the folder I have associated to the ftp service is already associated to SMB service that is working well.


    Thanks any help

  • Yes. Mine is associated with the SMB service and working very well also. It's not like I use FTP a lot anymore, but I do use from time to time. It worked fine on my OMV5 install.

    Here is my output, looks like there might be a configuration issue.


    tail -f /var/log/syslog

    Jul 4 18:05:18 OMV monit[752]: 'proftpd' failed to start (exit status 1) -- '/etc/init.d/proftpd restart': Job for proftpd.service failed because the control process exited with error code.#012See "systemctl status proftpd.service" and "journalctl -xe" for details.#012

    Jul 4 18:05:48 OMV monit[752]: 'proftpd' process is not running

    Jul 4 18:05:48 OMV monit[752]: 'proftpd' trying to restart

    Jul 4 18:05:48 OMV monit[752]: 'proftpd' start: '/etc/init.d/proftpd restart'

    Jul 4 18:05:48 OMV systemd[1]: Starting ProFTPD FTP Server...

    Jul 4 18:05:48 OMV proftpd[40344]: Checking syntax of configuration file

    Jul 4 18:05:48 OMV proftpd[40344]: 2021-07-04 18:05:48,334 OMV proftpd[40344]: fatal: unknown configuration directive 'IdentLookups' on line 22 of '/etc/proftpd/proftpd.conf'

    Jul 4 18:05:48 OMV systemd[1]: proftpd.service: Control process exited, code=exited, status=1/FAILURE

    Jul 4 18:05:48 OMV systemd[1]: proftpd.service: Failed with result 'exit-code'.

    Jul 4 18:05:48 OMV systemd[1]: Failed to start ProFTPD FTP Server.

    Jul 4 18:06:18 OMV monit[752]: 'proftpd' failed to start (exit status 1) -- '/etc/init.d/proftpd restart': Job for proftpd.service failed because the control process exited with error code.#012See "systemctl status proftpd.service" and "journalctl -xe" for details.#012

  • Hi overhome. Yours log is very similar to the mine.


    I also noted that the error:

    Code
    fatal: unknown configuration directive 'IdentLookups' on line

    comes from a config from ftp, but I think it is a script from OMV which adds that key.

    At the moment I don't know what to try.

  • It's because the ident-Module is not loaded by default. Just remove the leading # in /etc/proftpd/modules.conf


    #This is required only if you need to set IdentLookups on

    #LoadModule mod_ident.c

  • fabiopaolini How is this possible? OMV5 is based on Debian Buster which uses ProFTPd 1.3.6. In this version the mod_ident is compiled by default and not as an external module that needs to be enabled. Are you using a backport from Debian Bullseye? Using backports is not supported in OMV because of exactly the problem you are facing now, backports break existing configurations and introduce new features that are not reflected by the deployment scripts.

  • fabiopaolini How is this possible? OMV5 is based on Debian Buster which uses ProFTPd 1.3.6. In this version the mod_ident is compiled by default and not as an external module that needs to be enabled. Are you using a backport from Debian Bullseye? Using backports is not supported in OMV because of exactly the problem you are facing now, backports break existing configurations and introduce new features that are not reflected by the deployment scripts.

    Sorry, probably I made a mistake. I have downloaded the two isos and I thought that I had installed the 5. Now I have changed my instalation where I have installed the Debian and then installing the OMV. My actual install is really the "6.0-12 (Shaitan)". I have the other in a pendrive to confirm soon, but good chance it be a version 6. I will also soon try the suggestions about the fix. Thanks

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!