IP security camera record to NAS

  • i bought some Amcrest IP security cameras specifically because they advertise they can record directly to a NAS via NFS share.
    im running OMV 5.6.12-1(Usul) on a raspberry pi 4 8gb. installed on debian buster lite (with no GUI as recommended.

    1TB wd blue sata SSD plugged in via usb3.0


    ive created a shared folder called "security" and its relative path is shown as "security/" and a long absolute path, with read/write permissions for the user and group "pi"
    i setup an NFS share, with read/write permissions for everybody.


    the pi is running correctly, OMV is running correctly. when i login into the IP camera, and setup the NAS as storage, i enter my Pi's IP address, and the relative path to the shared folder(i tried entering the absolute path but the UUID disk name is too long to enter into the field in my cameras web UI, so i made a symlink in OMV with a shorter path name leading to the absolute path which ended with the same error.)

    whenever i save the settings on my security camera, and look at the system logs in OMV it says "rpc.mountd[random-number-here]: Bad path in mount request from 192.168.0.146: "security/"

    the camera is %100 trying to make contact with the NAS, but i cant for the life of me figure out what i am supposed to put into the "remote directory" field.
    ive been fucking with it for days. updating firmware, changing file and folder permissions, shared folder names etccc..

    i think it could also possibly be some kind of user/group file permission problem, maybe the cameras dont have the proper authorization to write in that directory, and im just missing the easy way to fix it...
    camera is an Amcrest ip5m-d1188ew-28mm

    some help would be much appreciated.

    IFFFFF i can get this to work, ive got a setup i can share for cheap DIY security without having to buy those expensive network video recorders

  • I think your remote directory is wrong.


    Granted, this is my Ubuntu laptop... but in my fstab this is how I set my network connection


    Code
    192.168.1.166:/Data
    192.168.1.166:/Media

    So if it were me... I would remove that trailing / and try again... and if that doesn't work, try to make it /security instead.

    Can you post a pic of the NFS share window as well?


    Example:


    Air Conditioners are a lot like PC's... They work great until you open Windows.


Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!