Can't create file system: read error 27

  • I have a MediaSonic PRORAID enclosure (RAID 5, ~27.3TB) that I want to share on our network as a backup target but whenever I try to wipe this disk I get the following error:


    When I try to create a file system on it I get this error:

    Code
    Error #0:
    OMV\ExecException: Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C.UTF-8; partprobe '/dev/sdb' 2>&1' with exit code '1': Error: end of file while reading /dev/sdb in /usr/share/openmediavault/engined/rpc/filesystemmgmt.inc:649
    Stack trace:
    #0 /usr/share/php/openmediavault/rpc/serviceabstract.inc(588): Engined\Rpc\OMVRpcServiceFileSystemMgmt->Engined\Rpc\{closure}('/tmp/bgstatusNN...', '/tmp/bgoutput4u...')
    #1 /usr/share/openmediavault/engined/rpc/filesystemmgmt.inc(689): OMV\Rpc\ServiceAbstract->execBgProc(Object(Closure), NULL, Object(Closure))
    #2 [internal function]: Engined\Rpc\OMVRpcServiceFileSystemMgmt->create(Array, Array)
    #3 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)
    #4 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('create', Array, Array)
    #5 /usr/sbin/omv-engined(537): OMV\Rpc\Rpc::call('FileSystemMgmt', 'create', Array, Array, 1)
    #6 {main}


    I've poked around with gdisk and fdisk and cfdisk and tried different repair/rebuild/delete/create options but no matter what I still get this same error. I don't fully know what I'm doing tho so I may not have done the right thing or in the right way. However, I can plug it up to a Windows desktop and use Disk Management to delete the volume, create a new one, format it as exfat and then plug it up to OMV and it will mount and I can share it.


    What might be the problem here? How can I go about troubleshooting this? I have another, older, smaller, MediaSonic enclosure (RAID 5, ~2.73TB) that I'm already sharing the same way on this server and it's working fine.


    Thanks in advance!

    omv 5.5.23-1 (usul) on RPi4 with Kernel 5.4.x

    Edited 5 times, last by dev_willis ().

  • Have you tried wiping the disks before trying to create file systems?

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 5.x on Chenbro NR12000 1U 1x 8m Quad Core E3-1220 3.1GHz 16GB ECC RAM.

  • Just FYI, I was never able to resolve this. I have no trouble with this drive on Windows or Ubuntu desktops and it worked fine on the RPi4 after I removed OMV and installed DietPi instead so it seems like it must be some obscure bug in OMV.

    omv 5.5.23-1 (usul) on RPi4 with Kernel 5.4.x

  • it seems like it must be some obscure bug in OMV.

    Always the suspect; seldom proved guilty.

    How did you erase, format, and mount the disk in OMV?

    Easy data backup: In a Scheduled Job: rsync -av --delete /srv/dev-disk-by-label-SOURCE/ /srv/dev-disk-by-label-DESTINATION/ (HT: Getting Started with OMV5)
    OMV 5 (current) - Thinkserver TS140, Nextcloud, Plex, Airsonic, Navidrome, Ubooquity, Digikam, Wetty, & Heimdall - NanoPi M4 (v.1): backups using Rsync and Rsnapshot - Odroid XU4 (Using DietPi): PiHole - hc2, xu4, Pi 3B+, Odroid H2, and VirtualBox: Testing and playing - Mac user converting to Linux, Debian 10 KDE.

  • Always the suspect; seldom proved guilty.

    How did you erase, format, and mount the disk in OMV?

    OMV was not the suspect, initially. I assumed I had failed to account for something. I still wouldn't say that it's been proven to be OMV but given that I was able to successfully wipe, format and mount the drive in Ubuntu, DietPi and Windows, it's looking like it must be something to do with OMV since that's the only place it doesn't work. I'm sure it's a few different things coming together in some unanticipated way. Perhaps something about the combination of OMV, an RPi4, and the size of this drive. I'm just guessing tho.


    Below is an overview of what I tried. I had some extended discussion with crashtest about it in this thread as well. I didn't intend to highjack that thread but I couldn't get crashtest to come look at this one (I also had some trouble getting him to read and understand my posts and wound up repeating myself a lot. I assume he must be busy.)



    I tried to erase it with the "Wipe" button in OMV. When that didn't work, I tried it with the `wipefs --all --force` command but had the same problem. I tried it a second time as well per crashtest's advice but it didn't help.


    I tried to format it from within OMV and, when that didn't work, I tried it with `gparted` but that failed as well. It kept telling me the backup GPT headers were corrupt and that it was rebuilding the backup from the main headers but whatever it was doing didn't seem to stick because it rebuilt them a dozen times or so in total but still kept saying they were corrupt. I ran `gparted` on Ubuntu but it didn't find any problems with the headers so I'm not convinced they were actually corrupt.


    I was never able to get to the point of mounting the disk while working entirely in OMV because I was never able to create a file system with it. Since I had no trouble with the drive in Ubuntu, I created an EXT4 file system there and then tried mounting that in OMV but still had the same issue. I was beginning to think the problem might be with the RPi4, so, to test that, I removed OMV and installed DietPi. I had no issues at all wiping, formatting and mounting the drive on the RPi4 while running DietPi. So, I set up the Samba shares like I needed and have just been using DietPi ever since. OMV was overkill for me anyway.

    omv 5.5.23-1 (usul) on RPi4 with Kernel 5.4.x

    Edited once, last by dev_willis ().

  • MediaSonic PRORAID enclosure

    I'd guess you configured it to use hardware RAID options, right?
    if yes, could you

    • attach a photo of the backside like below?
    • output of commands:
      • uname -a
      • lsusb -t && lsusb -v



    omv 5.6.16-1 (usul) on RPi4/4GB with Kernel 5.10.63 and WittyPi 3 V2 RTC HAT

    2x 6TB HDD formatted with ext4 in Icy Box IB-RD3662-C31 / hardware supported RAID1

    For Read/Write performance of SMB shares hosted on this hardware see forum here

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!