Trouble while saving a share in ftp

  • Hi,


    i can't create a share. Saving ends allways with an error.


    SMB works fine....


    Any ideas?

    Au deutschem Boden darf nie wieder der Gin ausgehen!

    Edited once, last by Pinfeed ().

  • Hi,


    sry.my bad :)


    Here are the details of the errormessage.


    If i do nothing, I can use ftp.


    But the yellow ribbon is allways visible then. And says, i need to save the configuration. And that didn't work.

    Files

    • Error1.txt

      (18.03 kB, downloaded 11 times, last: )

    Au deutschem Boden darf nie wieder der Gin ausgehen!

  • please post the output of these two commands using the </> code button; you have to run the commands in this sequence

    systemctl start monit.service to start the monit service (which will fail)

    journalctl -xe to get some information why the start of the service fails

  • here cames the output. Didn't findde code button, logged in via ssh. hope the output is the same.


    --

    -- The job identifier is 39532.

    Jul 21 16:28:33 NAS systemd[26234]: Reached target Default.

    -- Subject: A start job for unit UNIT has finished successfully

    -- Defined-By: systemd

    -- Support: https://www.debian.org/support

    --

    -- A start job for unit UNIT has finished successfully.

    --

    -- The job identifier is 1.

    Jul 21 16:28:33 NAS systemd[26234]: Startup finished in 219ms.

    -- Subject: User manager start-up is now complete

    -- Defined-By: systemd

    -- Support: https://www.debian.org/support

    --

    -- The user manager instance for user 0 has been started. All services queued

    -- for starting have been started. Note that other services might still be starting

    -- up or be started at any later time.

    --

    -- Startup of the manager took 219502 microseconds.

    Jul 21 16:28:35 NAS php[17266]: Unknown or deprecated time zone [tz=]. Please reconfigure your time zone settings.

    Jul 21 16:28:35 NAS omv-engined[26253]: Unknown or deprecated time zone [tz=]. Please reconfigure your time zone settings.

    Jul 21 16:28:41 NAS php[17264]: Unknown or deprecated time zone [tz=]. Please reconfigure your time zone settings.

    Jul 21 16:28:41 NAS omv-engined[26260]: Unknown or deprecated time zone [tz=]. Please reconfigure your time zone settings.

    Jul 21 16:28:45 NAS systemd[1]: Starting LSB: service and resource monitoring daemon...

    -- Subject: A start job for unit monit.service has begun execution

    -- Defined-By: systemd

    -- Support: https://www.debian.org/support

    --

    -- A start job for unit monit.service has begun execution.

    --

    -- The job identifier is 39659.

    Jul 21 16:28:46 NAS monit[26269]: Starting daemon monitor: monit/etc/monit/conf.d/openmediavault-filesystem.conf:31: Service name conflict, filesystem_srv_dev-disk-by-uuid-4098ce4c-4b9f-4b93-bb18-c79e0a53a750 already defined '"/srv/dev-d

    Jul 21 16:28:46 NAS monit[26269]: /etc/monit/conf.d/openmediavault-filesystem.conf:36: Service name conflict, mountpoint_srv_dev-disk-by-uuid-4098ce4c-4b9f-4b93-bb18-c79e0a53a750 already defined ''/srv/dev-disk-by-uuid-4098ce4c-4b9f-4b93

    Jul 21 16:28:46 NAS monit[26272]: /etc/monit/conf.d/openmediavault-filesystem.conf:31: Service name conflict, filesystem_srv_dev-disk-by-uuid-4098ce4c-4b9f-4b93-bb18-c79e0a53a750 already defined '"/srv/dev-disk-by-uuid-4098ce4c-4b9f-4b93

    Jul 21 16:28:46 NAS monit[26272]: /etc/monit/conf.d/openmediavault-filesystem.conf:36: Service name conflict, mountpoint_srv_dev-disk-by-uuid-4098ce4c-4b9f-4b93-bb18-c79e0a53a750 already defined ''/srv/dev-disk-by-uuid-4098ce4c-4b9f-4b93

    Jul 21 16:28:46 NAS monit[26269]: failed!

    Jul 21 16:28:46 NAS systemd[1]: monit.service: Control process exited, code=exited, status=1/FAILURE

    -- Subject: Unit process exited

    -- Defined-By: systemd

    -- Support: https://www.debian.org/support

    --

    -- An ExecStart= process belonging to unit monit.service has exited.

    --

    -- The process' exit code is 'exited' and its exit status is 1.

    Jul 21 16:28:46 NAS systemd[1]: monit.service: Failed with result 'exit-code'.

    -- Subject: Unit failed

    -- Defined-By: systemd

    -- Support: https://www.debian.org/support

    --

    -- The unit monit.service has entered the 'failed' state with result 'exit-code'.

    Jul 21 16:28:46 NAS systemd[1]: Failed to start LSB: service and resource monitoring daemon.

    -- Subject: A start job for unit monit.service has failed

    -- Defined-By: systemd

    -- Support: https://www.debian.org/support

    --

    -- A start job for unit monit.service has finished with a failure.

    --

    -- The job identifier is 39659 and the job result is failed.

    Jul 21 16:28:47 NAS php[17266]: Unknown or deprecated time zone [tz=]. Please reconfigure your time zone settings.

    Jul 21 16:28:47 NAS omv-engined[26274]: Unknown or deprecated time zone [tz=]. Please reconfigure your time zone settings.

    Jul 21 16:28:53 NAS php[17264]: Unknown or deprecated time zone [tz=]. Please reconfigure your time zone settings.

    Jul 21 16:28:53 NAS omv-engined[26281]: Unknown or deprecated time zone [tz=]. Please reconfigure your time zone settings.

    Au deutschem Boden darf nie wieder der Gin ausgehen!

  • Jul 21 16:28:46 NAS monit[26269]: Starting daemon monitor: monit/etc/monit/conf.d/openmediavault-filesystem.conf:31: Service name conflict, filesystem_srv_dev-disk-by-uuid-4098ce4c-4b9f-4b93-bb18-c79e0a53a750 already defined '"/srv/dev-d

    Did you manually edit config.xml?


    What is the output of

    omv-confdbadm read --prettify conf.system.filesystem.mountpoint

  • Sorry, was on business travel the last day. I'll try the next things this night. I'll report then..

    Au deutschem Boden darf nie wieder der Gin ausgehen!

  • I never edited the config.xml manually...

    Au deutschem Boden darf nie wieder der Gin ausgehen!

  • This mountpoint is defined twice:

    /srv/dev-disk-by-uuid-4098ce4c-4b9f-4b93-bb18-c79e0a53a750


    To fix this

    make bakup of config.xml

    cp /etc/openmediavault/config.xml /etc/openmediavault/config.xml.bak


    thend edit the original file with

    nano /etc/openmediavault/config.xml


    find the first section with this mountpoint (there will be two). It starts with <mntent> and stops with </mntent> and looks like this

    Code
    <mntent>
    <uuid>4098ce4c-4b9f-4b93-bb18-c79e0a53a750</uuid>
    <fsname>/dev/disk/by-uuid/xxxxx</fsname>
    <dir>/srv/dev-disk-by-uuid-</dir>
    <type>ext4</type>
    <opts>defaults,nofail,user_xattr,noexec,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0,acl</opts>
    <freq>0</freq>
    <passno>2</passno>
    <hidden>0</hidden>
    </mntent>

    Delete one of the sections and save the file with Ctrl+x and y


    Then deploy the change with

    omv-salt deploy run fstab

  • Hi,


    problem solved. I can switch on and off the ftp server. And create shares :D


    Any idea why the mountpoint was defined twice? I never edited the config.xml manually.

    FTP runs fine now :)


    Thanks you for your support. I would'nt find it by myself :)

    Au deutschem Boden darf nie wieder der Gin ausgehen!

  • macom

    Added the Label OMV 5.x
  • macom

    Added the Label resolved

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!