Problems with Spindown, HD-Idle

  • Hi

    I have some trouble with the Spindown/Spinup using HD-Idle.

    I used this Guide for install hd-idle ->

    [How-To] Spin-down hard drives with hd-idle

    hdparm is disabled.

    Every time after a reboot of the Raspberry Pi 4 the spindown works fine but after 20-30 minutes the HDD's, 2x 2TB Seagate Barracuda
    ST2000DM008 in an Icy Box IB-RD3621U3, have a spinup on its own without any access at the HDD's from my site,

    but in the status is most showing still spindown
    (the -i 320 is just for trying)

    Status after reboot and the HDD's are correctly in the spindown:



    Status show sda in spinup and sdb in spindown but both are in spinup on its own


    A few minutes later sda is shown as spindown again but its still in spinup



    My /etc/default/hd-idle:


    the status-all

    Installed in OMV are the extras (enable) and autoshutdown (disable), only NFS and SSH is activ.
    APM is also disabled.
    After going in the spinup, no matter whether it is displayed or not, they never go in the spindown again until
    I make a reboot of the Raspberry.

    Why are the system going on its own in the spinup? Whats wrong?

    Regards
    Holger

  • just to confirm it is not working as expected:


    to deactivate hdparm for the two drives:

    hdparm -B255 /dev/sda

    hdparm -B255 /dev/sdb

    to manually spin down the drives

    hd-idle -t /dev/sda

    hd-idle -t /dev/sdb

    to check if the drives are spun down

    hdparm -C /dev/sd[ab]


    They should show both as "standby". If they do show as "standby" check after some time if the spun up again.


    If yes, you need to find out, what is accessing the drives. I would use "fatrace" for that, but I think it is not available for RPi.


    One think to check is SMART. What are your SMART settings.

    The firmware in the icy box might also do some not so obvious things. Might be worth checking in their forum.

  • One think to check is SMART. What are your SMART settings

    Hi

    SMART in OMV ist disabled.

    I had deactivated hdparm for both drives but I did it again,
    after that I try to manually spin down the drives and it was shown me


    Code
    Jul 29 16:13:57 raspberrypi systemd[1]: Started hd-idle - spin down idle hard disks.
    Jul 29 16:13:57 raspberrypi hd-idle[725]: symlinkPolicy=0, defaultIdle=320, defaultCommand=scsi, debug=false, logFile=/v
    Jul 29 16:21:14 raspberrypi hd-idle[725]: sda spindown
    Jul 29 16:21:15 raspberrypi hd-idle[725]: sdb spindown


    but they spin and hdparm -C show

    Code
    pi@raspberrypi:~ $ sudo hdparm -C /dev/sda
    /dev/sda:
    drive state is: standby
    pi@raspberrypi:~ $ sudo hdparm -C /dev/sdb
    /dev/sdb:
    drive state is: standby

    and also here the drives are in spinup.

    I just make a reboot and will see what will happen

  • No good news, its always the same...

    Maybe this syslog helps to find a solution


    Samba is deactivated, I just use NFS and SSH


    SMART in OMV is disabled but I find this in the syslogs

  • "standby" means, the drives are not rotating

    I know but I have a power consumption meter in the power lane, if the
    drives are in the spin down the raspi and the box use around 6W, are they in
    spin up then around 15W and I can hear the drives rotating...

  • Might be as well, that the Icy Box has its own spindown mechanism

    I called the support this morning and the Icy Box has no own spindown mechanism
    and no own logs or anything else.
    Maybe I will order external cases for the HDD's and try to connect the drives individually
    at the USB3 ports...

  • I have the USB-C version of that box and it works correctly with the power management from OMV.

    Never used/needed hd-idle.


    The way it's configured in OMV is:



    The 2 disks are running in Single Mode with a BTRFS RAID1 filesystem that makes both spin up with a slight delay when there's data written to it.

    But after a while, they spin down normally and stay that way until there's some activity: either access to the data or the cronjobs for cleanup or maintenance.


    The thing that I had to be sure was that there was nothing constantly calling up the disks so I only have a SMB share (that I don't use that much) and the Nextcloud DATA.

    When at home, me and the Wife have our phones in Sync with NC which makes it spin up and down quite often (due to taking pictures with the phone and almost instantly, it uploads them to NC), but during the "dead" hours, it is pretty much silent.


    For starters, just try to remove all access to the disks, and see if they aren't beeing call.

    The disks should spin down normally.

  • Samba is deactivated, I just use NFS

    my setup is the opposite and the box works as expected



    be sure (...) nothing constantly calling up the disks

    thats exactly right

    omv 5.6.13-1 (usul) on RPi4/4GB with Kernel 5.10.17 and WittyPi 3 V2 RTC HAT

    2x 6TB HDD formatted with ext4 in Icy Box IB-RD3662-C31 / hardware supported RAID1

    For Read/Write performance of SMB shares hosted on this hardware see forum here

  • Hi

    thanks for your answers! I hopefully find the solution

    RE: Raspberry Pi + IcyBox Standby????

    In that threat the solution was

    Code
    systemctl disable smartd
    systemctl mask smartd
    systemctl disable smartmontools
    systemctl mask smartmontools

    After that the drives go in the spindown and stay there but I don't have
    access to the NAS.
    After enable und unmask smartd and let the smartmontools on disable
    and mask it seems that now it works how it should!
    I will wait a few days and keep my fingers off the current settings!

  • 2x 2TB Seagate Barracuda
    ST2000DM008

    According to this list https://hardzone.es/tutoriales…tes/lista-disco-duro-smr/ your disks are type SMR. SMR disks need to reorder data automatically. They do this when they are on standby. That is why they rotate regularly without any access.

    Extra note: Be careful with the RAID with these disks, they can give problems.

    OMV 5, Intel core i3 3225, 8GB RAM, PendriveUSB system, ZFS RaidZ 5xWD Red 4TB, 1x120GB SSD Docker

    I DO NOT SPEAK ENGLISH. I translate with google, sorry if sometimes you don't understand me well:)

    A backup is like a belt, you will miss it when your pants fall off. Do you want to stay in your underpants?

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!