Upgrade OMV from 4.1.36-1 (Arrakis)

  • Hello, I have a really old OMV Nas. I would like to upgrade to the last revision. Is there a chance to upgrade or is it better to use a fresh install ?

    Thank you

    • Official Post

    Upgrade Scripts for non-interactive major release upgrades (2->3, 3->4, 4->5)

    if you have omv-extras installed make sure you have the github repos before you try the upgrade::

    omv-extras repos moving to github

  • Thank you for your answer. It seems OMV upgraded to 5. WEb interface is active but it is asking to apply edits. It runs for a bit of time and then results a Communication Failure.

    I'm able to browser CIFS share in windows, but Nakivo is not. Maybe something was wrong during the upgrade process. Any hints ?

    Thank you

  • Yes of course. As I said I apply edits and it runs for a bit of time and then results in: Communication Failure. And asking once again to apply edits.

    Thank you

  • I finally got an error. It seems something relative to proftpd . I was trying to remove or purge it but it seems to depend from:

    openmediavault openmediavault-lvm2 openmediavault-omvextrasorg openmediavault-rsnapshot proftpd-basic proftpd-mod-vroot

    Complete error from pastebin

    Thank you

  • Here it is, thank you.

    • Official Post

    ago 12 10:34:16 openmediavault proftpd[63875]: Starting ftp server: proftpdstart-stop-daemon: matching on world-writable

    there seems to be some output missing. Could you please check by running the command again?

    If not, try

    systemctl --no-pager status proftpd.service

  • Thank you, here is the output of your last command:

  • Hello, it seems I solved the problem. Deleting /run/proftpd.pid file solved the issue. Saving the changes on admin web page took a bit of time respect the 4.x OMV version, but now I don't have any errors anymore.

    Thank you

    • Official Post

    Saving the changes on admin web page took a bit of time respect the 4.x OMV version,

    Yes. This is something you will frequently note in the future. Applying changes takes much longer on OMV4 than on OMV5. It is due to the new architecture of OMV5.

    Deleting /run/proftpd.pid file solved the issue

    Was searching for a pointer to that issue. Strange that the pid file was not mentioned in your output.

    Glad you were able to fix it.

  • macom

    Set the Label from OMV 4.x to OMV 5.x
  • macom

    Added the Label resolved

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!