error 500 after upgrade to OMV 5

  • I tried to upgrade my OMV 4 to 5, but ended up with a system with no GUI - Firefox shows a blank page, while Chrome-based browsers show Error 500.


    I started the upgrade with the script from https://github.com/dleidert/openmediavault-upgrade/tree/4. This first failed with a python TypeError, which was resolved by removing the bintray repos with

    Code
    sudo sed -i "/bintray/d" /etc/apt/sources.list.d/*
    sudo sed -i "/backports/d" /etc/apt/sources.list

    After that, I could re-start the script, but it then failed with an grub issue - I had switched the boot drive at some point, and grub still had the old disk id.

    After fixing grub, the script would no longer run, since it detected that I am already on Buster.

    Instead, I did apt upgrade and apt dist-upgrade, which mostly worked, except that I experienced the problem with pinned debian repos, causing salt-* packages to sit on old versions.

    After "fixing" this with sudo apt install salt-minion=3003.2+ds-1 salt-common=3003.2+ds-1, I did some upgrades, re-installation of openmediavault package and a restart - and ended up in a situation where I can SSH to the box, but there is no GUI...


    In addition, I see that sudo omv-firstaid fails with ModuleNotFoundError: No module named 'openmediavault.subprocess', which could be connected to the fact that sudo apt policy openmediavault-omvextrasorg returns

    Code
    openmediavault-omvextrasorg:
    Installed: 4.1.16
    Candidate: 4.1.16
    Version table:
    *** 4.1.16 100
    100 /var/lib/dpkg/status

    Am I missing some apt sources?


    What can I do now?

  • crashtest

    Approved the thread.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!