OMV GUI access doesn't work

  • Hi


    When I try to login to the OMV GUI, I get stuck in the login screen. I can enter my username and password, but pressing "login" just refreshes the page.
    I have read a lot about firewall problems, but I cannot remember that I have changed something recently. Also putting my NAS into a DMZ didn't help.

    I did not get anywhere with my own research, but maybe someone has ideas and can help me finding, understanding and fixing the problem.


    Accessing files on my NAS and using Putty to connect to the NAS works fine.

    Thanks already
    Silverhammer

  • You are not supposed to use your username and password.


    Instead use these credentials:


    admin:openmediavault


    That is, user "admin" and password "openmediavault".


    Make sure to change that password the first time you login.

    Be smart - be lazy. Clone your rootfs.
    OMV 5: 9 x Odroid HC2 + 1 x Odroid HC1 + 1 x Raspberry Pi 4

  • Follow the guide. The next steps are


    cd / to change to the root of the OS file system

    du -xhd1 du will show you the size of each folder on the root (x: do not descend into other filesystem; h: display output in human readable format; d1: show only first level of directories)

  • Yes. That is your issue.

    Sorry for not replying this long. I was away the whole weekend.
    I did identify the folders which take up all space and those are indeed the folders in ./docker

    To be honest I did not really finish to setup plex in the docker and would prefer to completely remover docker again. Can I delete the folder ./docker in putty or do I need to remove it in a "clean" way?
    If so: where can I find information about how to do that? (alawys keep in mind that I cannot login to OMV GUI) :/

  • Sorry for not replying this long. I was away the whole weekend.
    I did identify the folders which take up all space and those are indeed the folders in ./docker

    To be honest I did not really finish to setup plex in the docker and would prefer to completely remover docker again. Can I delete the folder ./docker in putty or do I need to remove it in a "clean" way?
    If so: where can I find information about how to do that? (alawys keep in mind that I cannot login to OMV GUI) :/

    yes.


    systemctl stop docker

    rm -R /var/lib/docker


    You should be able to log in now.


    However, if you have other containers you've already setup, etc..


    Find a path your larger storage drives... and move the directory there.

    systemctl stop docker


    mv /var/lib/docker /srv/dev-disk-by-uuid-some-numbers/


    That will make your docker folder location /srv/dev-disk-by-uuid-some-numbers/docker


    Now go to the docker plugin, and change the path to your containers to


    /srv/dev-disk-by-uuid-some-numbers/docker

    and save


    Back at the command line, systemctl restart docker


    docker is moved to the larger drive so you can log in to the webUI, and you didn't lose any of your current setup.

    Air Conditioners are a lot like PC's... They work great until you open Windows.


    Edited 2 times, last by KM0201 ().

  • KM0201

    Added the Label resolved
  • Just make sure you fix the actual problem, or you'll be right back here again. When you set up docker again, use the plugin to put your containers folder on on one of your data drives (which are presumably much larger than your OS drive)

    Air Conditioners are a lot like PC's... They work great until you open Windows.


Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!