I broke portainer

  • I saw there was a new portainer so I did an install it and now its broken. I'm using OMV5

    Installing portainer I get this


    Docker storage ::

    Agent port:: 8000

    Web port:: 9000

    Opt-out :: 1

    arch :: amd64

    option :: portainer

    state :: install

    extras :: 5.3.4

    DNS error. Exiting ...

    Done.


    It worked before not sure what to do :(

  • wow so OMV is broken?

    Well, no. What is broken is Portainer. I did not have any other solution for fixing Portainer so ended up re-installing the whole thing. Good thing was that, MariaDB database (I use it for 5 installations of Kodi) did not get lost so I did not have to rebuild that. Just pain in the neck.

    EndeavourOS

    Linux Mint 20.2 "Uma", Cinnamon DT

    OMV5 NAS, 20TB storage

  • what if i did it command line

    Code
    sudo docker pull portainer/portainer-ce
    sudo docker run --restart=always --name=portainer -d -p 9000:9000 -v /var/run/docker.sock:/var/run/docker.sock portainer/portainer-ce
  • what if i did it command line

    Code
    sudo docker pull portainer/portainer-ce
    sudo docker run --restart=always --name=portainer -d -p 9000:9000 -v /var/run/docker.sock:/var/run/docker.sock portainer/portainer-ce

    I think I tried this but did not worked for me. Might work for you, dough.

    EndeavourOS

    Linux Mint 20.2 "Uma", Cinnamon DT

    OMV5 NAS, 20TB storage

  • I had the same problem. Ended up with re-installation of OMV5. It took couple of hours to reconfigure and update but Portainer is back.

    Note: Do NOT reformat OMV drive, just re-install.

    I'm sorry, that is the most ridiculous advice I've seen on this forum . The error clearly states there is a DNS issue.


    OP... post the output of


    Code
    ping -c 5 aol.com


    Most likely it's going to tell you something about the host could not be reached because while your network device is working (so you can use SSH, the webUI, etc..) it cannot access the Internet, so you can't get updates, the new container, etc..


    At that point, as root run the command:

    Code
    omv-firstaid

    I believe the first option, is to reconfigure your network controller. Choose that, choose your network device, then set it up (I'm assuming your router is probably using DHCP, so it should be pretty straight forward to take the defaults)


    once you're done, test that it's working again..


    Code
    ping -c 5 aol.com

    and you should get a successful ping result.


    Now, go back to the webUI, run apt clean again as raulfg3 suggested, then reinstall portainer.


    After that, you may want to check for system updates. Just be forewarned this could change your OMV IP address. (you'll get no access to anything)...


    If that's the case, download angryIP scanner to one of the devices on your network, and scan your network. It should find your OMV server and give you your new IP address. After that, if you need help setting it to your "old" IP, just post and I"m sure someone can talk you through setting a static IP.


    https://angryip.org/

    Air Conditioners are a lot like PC's... They work great until you open Windows.


    Edited 4 times, last by KM0201 ().

  • Well, you are totally wrong. I had no issue with internet access, logging to OMV5, even accessing MariaDB through SQLyog. I DID all of the things you suggested and that did NOT work. So, instead assuming (and you know how to spell it) that someone is incompetent, look a little bit deeper first before jumping into conclusions.

    EndeavourOS

    Linux Mint 20.2 "Uma", Cinnamon DT

    OMV5 NAS, 20TB storage

  • Well, you are totally wrong. I had no issue with internet access, logging to OMV5, even accessing MariaDB through SQLyog. I DID all of the things you suggested and that did NOT work. So, instead assuming (and you know how to spell it) that someone is incompetent, look a little bit deeper first before jumping into conclusions.

    Then you had a different problem than him. I'm not wrong.. read the output of the error. It says right there...


    DNS error.. exiting.

    Air Conditioners are a lot like PC's... They work great until you open Windows.


  • Then you had a different problem than him. I'm not wrong.. read the output of the error. It says right there...


    DNS error.. exiting.

    As he described, after an attempt to update Portainer, Portainer died and would NOT reinstall. That is MY understanding of his initial problem. I had exactly the same issue and the only way to fix it, without super experts advice, I did what I did. BTW, do you have solution to the problem as described?. So far whatever you suggested did not work for me, so I am all ears.

    EndeavourOS

    Linux Mint 20.2 "Uma", Cinnamon DT

    OMV5 NAS, 20TB storage

  • root@Nas:~# ping: aol.com: Name or service not known

    -bash: ping:: command not found


    I'm running jellyfin it works fine


    tried 1st aid same thing

  • Again, jellyfin is irrelevant, unless you are accessing it from the Intenet. Your local network will work fine.


    Please post the output of omv-update

    Air Conditioners are a lot like PC's... They work great until you open Windows.


  • As he described, after an attempt to update Portainer, Portainer died and would NOT reinstall. That is MY understanding of his initial problem. I had exactly the same issue and the only way to fix it, without super experts advice, I did what I did. BTW, do you have solution to the problem as described?. So far whatever you suggested did not work for me, so I am all ears.

    Again, unless the portainer hub is down.. a DNS issue is very clearly in the error.


    I don't know what he's doing with that ping command.. but ping should be installed.

    Air Conditioners are a lot like PC's... They work great until you open Windows.


  • Err:1 http://security.debian.org/debian-security buster/updates InRelease

    Could not resolve 'security.debian.org'

    Err:2 https://dl.bintray.com/openmediavault-plugin-developers/usul buster InRelease

    Could not resolve 'dl.bintray.com'

    Err:3 https://download.docker.com/linux/debian buster InRelease

    Could not resolve 'download.docker.com'

    Err:4 http://linux.teamviewer.com/deb stable InRelease

    Could not resolve 'linux.teamviewer.com'

    Err:5 http://httpredir.debian.org/debian buster-backports InRelease

    Could not resolve 'httpredir.debian.org'

    Get:6 file:/var/cache/openmediavault/archives InRelease

    Ign:6 file:/var/cache/openmediavault/archives InRelease

    Err:7 https://dl.bintray.com/openmed…in-developers/usul-extras buster InRelease

    Could not resolve 'dl.bintray.com'

    Get:8 file:/var/cache/openmediavault/archives Release

    Ign:8 file:/var/cache/openmediavault/archives Release

    Err:9 http://deb.debian.org/debian buster InRelease

    Could not resolve 'deb.debian.org'

    Err:10 http://deb.debian.org/debian buster-updates InRelease

    Could not resolve 'deb.debian.org'

    Get:11 file:/var/cache/openmediavault/archives Packages

    Ign:11 file:/var/cache/openmediavault/archives Packages

    Get:12 file:/var/cache/openmediavault/archives Translation-en

    Ign:12 file:/var/cache/openmediavault/archives Translation-en

    Get:11 file:/var/cache/openmediavault/archives Packages

    Ign:11 file:/var/cache/openmediavault/archives Packages

    Get:12 file:/var/cache/openmediavault/archives Translation-en

    Ign:12 file:/var/cache/openmediavault/archives Translation-en

    Err:13 http://packages.openmediavault.org/public usul InRelease

    Could not resolve 'packages.openmediavault.org'

    Get:11 file:/var/cache/openmediavault/archives Packages

    Err:14 https://openmediavault.github.io/packages usul InRelease

    Could not resolve 'openmediavault.github.io'

    Ign:11 file:/var/cache/openmediavault/archives Packages

    Get:12 file:/var/cache/openmediavault/archives Translation-en

    Ign:12 file:/var/cache/openmediavault/archives Translation-en

    Get:11 file:/var/cache/openmediavault/archives Packages

    Ign:11 file:/var/cache/openmediavault/archives Packages

    Get:12 file:/var/cache/openmediavault/archives Translation-en

    Ign:12 file:/var/cache/openmediavault/archives Translation-en

    Get:11 file:/var/cache/openmediavault/archives Packages

    Ign:11 file:/var/cache/openmediavault/archives Packages

    Get:12 file:/var/cache/openmediavault/archives Translation-en

    Ign:12 file:/var/cache/openmediavault/archives Translation-en

    Get:11 file:/var/cache/openmediavault/archives Packages

    Ign:11 file:/var/cache/openmediavault/archives Packages

    Get:12 file:/var/cache/openmediavault/archives Translation-en

    Ign:12 file:/var/cache/openmediavault/archives Translation-en

    Get:11 file:/var/cache/openmediavault/archives Packages

    Get:12 file:/var/cache/openmediavault/archives Translation-en

    Ign:12 file:/var/cache/openmediavault/archives Translation-en

    Reading package lists...

    Reading package lists...

    Building dependency tree...

    Reading state information...

    Calculating upgrade...

    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

    Done.

  • andrzejls are you now satisfied that it's a DNS issue? His server is not online, just like the error said.


    OP, follow the instructions I gave you with omv-firstaid

    Air Conditioners are a lot like PC's... They work great until you open Windows.


  • fist aid gave me these options all i have is Ethernet I think its this one

    x x enp1s0 I211 Gigabit Network Connection x x



    br-76ef1c84e430 x x

    x x docker0 x x

    x x enp1s0 I211 Gigabit Network Connection x x

    x x enp2s0 I211 Gigabit Network Connection x x

    x x veth4deb226


    still nothing

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!