After deleting files, "Free disk space" is not increasing

  • I recently created an SMB share and is was being used as a temporary nas cache. I have removed the cache from the computer (a mac, no I do not need to empty the trash as it is a network share) and deleted all of the files on the SMB share but the free disk space is not showing as recovered (eg it has .75TB free before copying files to it and only 7.9MB free after, all of the files that used up the space have been deleted but it is still reporting only 7.9MB free on the entire device (even other shares)). I have tried rebooting but still only show 7.9MB free. Wonder if deleting the specific share would work?

  • Since I did not need the share any longer, I eventually ended up deleting the SMB share. Where I chose to delete the Share under the "Shared Folders" it asked if I wanted to delete the share and gave me the option to delete the data (chose to delete both, share and data). Even though the data was already deleted, I told it to delete the data which returned the free space. It would be nice to know if anyone has run into this issue before (where it did not release the free space) and how they were able to resolve it.

  • Is it not increasing in the webUI, or when you check it at the command line level? If it's the webUI, it might just take a second and you'd just need to refresh the page. At worst, you'd just need to clear your cache for the webUI (Hold Control and Shift, and hit R on most browsers, while in the webUi)

    Air Conditioners are a lot like PC's... They work great until you open Windows.


  • It was not increasing in my map to the network share. I tried rebooting both the openmediavault and my mac, but as for the network share, it was considered pretty much full and the free space was not released.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!