[Solved] SnapRaid I/O errors on reading content during check

  • Hoping someone can help here or point me in the right direction. When running a check I'm getting the error below and I'm having troubling figuring out how to resolve this. The system itself is up and running, I can access everything on it (as far as I can tell) but when running a check the content file is failing.

    Code
    Self test...
    Loading state from /srv/dev-disk-by-label-TOWER0/snapraid.content...
    Error stating the content file '/srv/dev-disk-by-label-TOWER2/snapraid.content'. Input/output error.

    What would be the recommended next steps here? If anyone has a link to an article of someone running into the same thing it would be great. I haven't had much success searching yet.

  • synapseattack

    Changed the title of the thread from “SnapRaid” to “SnapRaid I/O errors on reading content during check”.
  • Does the file that causes the error actually exist? If it exists have you run a fschk on the disk?

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 5.x on Chenbro NR12000 1U 1x 8m Quad Core E3-1220 3.1GHz 16GB ECC RAM.

  • Hi,


    Yes that runs and does not report an error.


  • So long as you have another good copy of the .content file I would try removing that one from the SnapRAID configuration and check again. If it passes check, delete the file from the disk and add it back into the configuration. Another new copy should appear eventually, and once it does you can run the check again.

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 5.x on Chenbro NR12000 1U 1x 8m Quad Core E3-1220 3.1GHz 16GB ECC RAM.

  • synapseattack

    Changed the title of the thread from “SnapRaid I/O errors on reading content during check” to “[Solved] SnapRaid I/O errors on reading content during check”.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!