clamav gives errors during enabling through gui

  • Hi,


    I cannot get clamav to work on my fresh install off omv5. When I try to enable it gives me this error part 1:

    Tried:

    - toggle enable on/off/on, same error message after 5 min

    - when I set database check to 0 I still get an error but much sooner and less long

    - added apparmor=0 to grub file. Reboot en reinstall plugin. Same error

    - tried to remove /run/clamav/clamd.ctl. Not present.

    - removed etc/clamav. reboot en reinstall. Same error

    - did a purge with apt-get purge clamav freshclam. Same error after install plugin

    - via putty as root did apt-get install clamav-base clamav-daemon clamav-freshclam clamdscan libclamav9. The output did mention installing additional packages like omv clamav stuff I think... No Icon in gui afterwards.

    - omv-salt deploy run clamav. Same error

    I am doing a test run in virtualbox. Same problems there.

    Can someone help me?


    Thank you

  • part 2:

  • part 3:

  • Tried tis also from putty:

    Now there is a icon in gui. Same errors when I enable it. I've noticed that the above error message regarding to openmediavault-clamav post installation script and subprocess may be the cause off all the subsequent problems. So the script needs to be updated??

  • thesorcerer

    Changed the title of the thread from “clamav gives errors after enabling gui” to “clamav gives errors during enabling through gui”.
  • I'm having the same issue. This thread came up in a search for the problem. Unfortunately I'm not very familiar with Clam AV or Salt, and I'm brand new to OMV. Mine is on a fresh install. Maybe this is caused by a bad update?

  • Mine is directly related to the Flashmemory plugin. When the logs get moved to folder2ram it causes the clamav-daemon to fail to be able to write to the log and causes it to fail. Even uninstalling the flashmemory plugin wasn't enough. I had to delete the logs in `/var/log/clamav`. Then clam started up without any problems. Guess I'll just won't use the flashmemory plugin. I didn't really need it as OMV is installed on an SSD, not a usb stick or SD card.

  • Thanks for your respons. On my virtualbox test setup same problem. Both clean installs of omv5 and omv6. On my previous setup using a ssd as boot same problem. Will have a look at `/var/log/clamav`.

    By the way do you have this dir? :

    path /var/lib/clamav/main


    Seems to be abscent here.

  • update.

    On my ovm6 vm it is working now. Next I tried it on my real nas running ovm5 from flash drive with flas plugin and that is working now too. Green lights accross the board.

    Very strange... I have no explanation why it suddenly has no errors when enabling... I haven't changed anything or doing something new.

  • New problem:


    When I check in gui dashboard both dots are not green. I have to re-enable it manually. For some reason autoshutdown plugin stops working to. Need to re-enable it the same way. :/

  • -Update-


    Did a clean install. This time I choose a different source mirror. Don't know if that was the problem. Most likely an error during system update in the past. So far running as it should.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!