Cron-apt probably not working

  • Hello,


    i noticed a thing lately. It seems that cron-apt is not running because in OMV i do not see any update until i manually check for them.


    How can i fix this? Also, with both OMV4 and OMV5 now i never received notifications for updates but only for the ones installed automatically.


    Thanks in advance!

  • Please make sure that you have installed the latest version (5.6.15), then run omv-salt deploy run cronapt. This should fix your issue.

    Thanks!

    Here is the output:


  • /etc/cron.daily/openmediavault-cron-apt


    Noted that an email is sent when a reboot is needed. I never received a message like that, i only receive notifications for new accesses and automatically installed security updates. Btw i have always activated all notifications :/

    I think the path for "reboot-required" is wrong in the script.

    Should be /run/reboot-required instead of /var/run/reboot-required

    https://www.debian.org/doc/deb…that-a-reboot-is-required


    EDIT: Just tried in a VM with an upgrade that includes a Kernel upgrade, but the file "reboot-required" is not created:/

  • I think the path for "reboot-required" is wrong in the script.

    Should be /run/reboot-required instead of /var/run/reboot-required

    https://www.debian.org/doc/deb…that-a-reboot-is-required


    EDIT: Just tried in a VM with an upgrade that includes a Kernel upgrade, but the file "reboot-required" is not created:/

    The path is correct, there is a symlink.


    Code
    # ls -alh /var/run
    lrwxrwxrwx 1 root root 4 Mär 3 2020 /var/run -> /run

    I guess ages ago the /var/run path was correct and surely mentioned that way in the Debian docs. I will change that in OMV6.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!