[solved] Many problems after an update

  • root@helios64:~# mount -o rw,remount /

    mount: /: cannot remount /dev/mmcblk2p1 read-write, is write-protected.

    I have tried to connect me to the OMV Dashboard with WebInterface login and I have been given this new kind of message :


    Error #0:

    OMV\Rpc\Exception: Failed to connect to socket: Connection refused in /usr/share/php/openmediavault/rpc/rpc.inc:141

    Stack trace:

    #0 /var/www/openmediavault/rpc/session.inc(57): OMV\Rpc\Rpc::call('UserMgmt', 'authUser', Array, Array, 2, true)

    #1 [internal function]: OMVRpcServiceSession->login(Array, Array)

    #2 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)

    #3 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('login', Array, Array)

    #4 /usr/share/php/openmediavault/rpc/proxy/json.inc(97): OMV\Rpc\Rpc::call('Session', 'login', Array, Array, 3)

    #5 /var/www/openmediavault/rpc.php(45): OMV\Rpc\Proxy\Json->handle()

    #6 {main}


    And now, my NAS is becoming invisible. I can’t reach it. The WebInterface login of OMV is gone (browser says « ERR_ADDRESS_UNREACHABLE » ) and i can’t SSH ( « ssh: connect to host port 22: No route to host » ).

    Is my NAS... dead ?!

  • Bad news: probably yes

    Good news: your data should be safe on the data drives

    Thank you, macom, I will take the good news !

    (I opened a topic on the Armbian—Helios64 forum. This topic is still invisible because it is awaiting validation from a moderator. I'll keep you informed.)

  • Hello everyone,

    I take the liberty of relaunching this topic 1/ to inform the readers in my situation that part of the problem has been solved by following the procedure explained HERE. (It seems that an update of Armbian is at the origin of the problem). And 2/ because my NAS under OpenMediaVault is unfortunately not yet fixed and not fully functional...

    When I do " sudo apt upgrade ", I get the following error message :

  • On OpenMediaVault, when I make a change in the settings and go for the validation (" The configuration has been changed. You must apply the changes in order for them to take effect. "), the procedure fails and I get this error message :

    Can anyone help me ?

  • maybe remove openmediavault-diskstats and run omv-upgrade

    apt-get remove openmediavault-diskstats


    It’s not working :

  • apt-get install -f

    No :

  • Please see RE: Error when applying config changes

  • Thomas25

    Changed the title of the thread from “Many problems after an update” to “[solved] Many problems after an update”.
  • macom

    Added the Label resolved

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!