Change user on shared folder (drive)

  • Hi all,


    Apologies for the probably redundant thread, I've tried to find a fix to my problem and I have to admit I'm out of obvious solution, at least given my basic level of understanding. I will be grateful for your help.


    Here is the issue:

    - I have 2 disks, 3 partitions connected to OMV : sda1, sdb1, sdb2

    - sda1 and sdb1 (both NTFS) work just fine, meaning I can read/write from any computer in my household

    - sdb2 (exfat) on the other hand is in read only, and I seem to be unable to change permissions

    - user permissions appear to be in order in the relevant GUI tab

    - I have tried the reset permissions plugin, but it returns "operation not permitted"


    I suspect the owner is not set properly, but I'm out of my depth in changing it. Somebody, help?


    Thanks a LOT in advance


    EDIT: added a screenshot of the current state of permissions in /srv folder. As you would guess, sdb2 is the one with UUID starting with 61. I tried chmod 777 -R on the folder, without success

  • Thanks for the answer. Unfortunately, I'm none the wiser. I think I need to change permissions at file system level, and not at shared drive level. But I am not sure whether it is possible, and I for sure don't know how to do it if it is.

  • I think I need to change permissions at file system level, and not at shared drive level. But I am not sure whether it is possible, and I for sure don't know how to do it if it is.

    If necessary (not usually) you can change the file system permissions in the GUI. Section << access permissions >> / << shared folders >> then select the folder, and then click the <<ACL>> tab. Whatever you do in there, do it with caution.


    read this before https://openmediavault.readthe…l#acl-access-control-list

  • I would like to add a question here also regarding permissions.


    I have a 3 separate drives all shared at root / folder level 2 drives are ntfs and one is vfat. I am just sorting out old files deleting and sorting etc.

    I am unable to delete anything off the vfat drive. I get this error - Access denied to smb://user@openmediavault.local:445/test2/Permaculture - Oscar/2014-calendar-landscape-2-pages-a4.doc.


    so I looked into the permissions as it had me stuck. there are no differences with the file permissions all 3 have the same permissions.


    user - can view and modify content

    group - can only view content

    others - can only view content


    I tried to edit the group and others to - can view and modify content


    but get the following response - Changing the attributes of files is not supported with protocol smb


    I also get that response with trying to change any permissions on folders in the ntfs drives.


    Is there any way I can change folder permissions through the OMV web interface? how can I solve this?


    My Access Control Management consists of a single user account called user that has read write permissions enabled in the privileges


    Thank you to everyone here, I have benefitted alot from all you support and have got to this point of having a functional NAS going. Im now just starting to work with it so encountering issues such as these that I am learning about.


    EDIT: since posting this I tried the following on the vfat formatted drive and was not able to perform any operations - move, copy/paste, create folder. all within the folder. the only operation that I could do was copy a file to the computer Im accessing the NAS on

  • thanks.

    I came accross this article vfat permissions in /etc/fstab and after skim reading briefly I though F*!K MS. I havent used MS for about 15 years and was surprised about discovering the format of that disk. clearly it was from a long time ago.


    Microshit just sux and Im bloody glad I dont use any of their crap, I had so many issues with XP and Vista and have nothing like that with GNU/Linux. Plus the community makes linux problems basically nonexistent.


    I ended up just copying all the files I wanted from the Vfat partition to another disc and will sort from there.


    Is NTFS a suitable format for OMV i intend to use Rsnapshot for back up and would like the disks to have a degree of compatibility with other computers should I need it.


    My set up is just a mini pc with usb 3 external drives

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!