Did I break OMV?

  • Apologies for being uneducated and breaking things;


    I have an OMV system on a Raspberry Pi that I try to keep mostly hands-off, and keep up to date with unattended upgrades. However I did something that seems to have broken things.


    The problems seem to have started when I accidentally installed 'ntp.' I did not realize what it was for, and that OMV uses chrony instead. Installing 'ntp' removed the packages `chrony openmediavault openmediavault-flashmemory openmediavault-omvextrasorg`


    When I tried to install them back, I got some errors.



    and




    I can go to the web-interface of OMV like normal, but I can't login. I get this error: `Failed to connect to socket: No such file or directory`

    Code
    Error #0:
    OMV\Rpc\Exception: Failed to connect to socket: No such file or directory in /usr/share/php/openmediavault/rpc/rpc.inc:141
    Stack trace:
    #0 /var/www/openmediavault/rpc/session.inc(57): OMV\Rpc\Rpc::call('UserMgmt', 'authUser', Array, Array, 2, true)
    #1 [internal function]: OMVRpcServiceSession->login(Array, Array)
    #2 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)
    #3 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('login', Array, Array)
    #4 /usr/share/php/openmediavault/rpc/proxy/json.inc(97): OMV\Rpc\Rpc::call('Session', 'login', Array, Array, 3)
    #5 /var/www/openmediavault/rpc.php(45): OMV\Rpc\Proxy\Json->handle()
    #6 {main}


    How badly did I screw up?


    EDIT: Doing omv-firstaid for submitting diagnostic to administrator:


    Code
    Submitting system diagnostic report to the administrator account. Please check your email mailbox ...
    Unknown script, /usr/share/openmediavault/sysinfo/modules.d/| not found.
    ERROR: Command '['omv-sysinfo', '|', 'mail', '-s', 'System diagnostic report', 'root']' returned non-zero exit status 100.
  • semitones

    Added the Label OMV 5.x
  • The problems seem to have started when I accidentally installed 'ntp.' I did not realize what it was for, and that OMV uses chrony instead. Installing 'ntp' removed the packages `chrony openmediavault openmediavault-flashmemory openmediavault-omvextrasorg`

    Why do people keep installing ntp?? Sorry, there have been way too many people doing that breaking their install and there is nothing OMV can do to stop since it is outside of OMV. You really need to remove ntp and reinstall the omv packages you removed. Not sure if your settings/database are still there but you have a mess.



    I have an OMV system on a Raspberry Pi that I try to keep mostly hands-off, and keep up to date with unattended upgrades. However I did something that seems to have broken things.

    OMV 5+ automatically installs security updates. You really shouldn't need unattended-upgrades. In my opinion, a server should be checked on once in a while and you can install updates/reboot then.

    omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Chrony is okay, but ntp was way better for me.

    We switched to chrony a couple of years ago at work (running on 5k+ VMs and physical servers). Been just as solid as ntp. Use it on CentOS/RHEL/Ubuntu with no issues. Just curious what ntp did better?

    omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • NTP was easy to setup, just put pools inside /etc/ntp.conf and all would be okay. As i remember , there was some problem with chrony and retail server, and register time synchronization. I can't remember anymore unfortunately.

  • I blindly tried to install ntp because 'last reboot' was giving me a nonsense value. I did not realize this was because a raspberry pi does not have a RTC, and reboots are always 1/1/1970 before chrony/ntp sync it.


    I have removed ntp, and reinstalled chrony, but I cannot reinstall openmediavault due to the error above. (Is it relating to LVM?)

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!