Das „neue“ Thema SMB-Freigaben (Ich benötige HILFE)

  • Das „neue“ Thema SMB-Freigaben (Ich benötige HILFE)



    Hallo zusammen,


    entschuldigt bitte das ich auf deutsch schreibe.



    Mein Problem - SMB Freigabe unter OMV / Zugriff von Windows


    Ich versuche seit einiger Zeit eine Freigabe über SMB/CIFS hinzubekommen. Ich habe unzählige Male und nach verschiendenen Anleitungen mit den Einstellungen, einiges Ausprobiert / Fehler gesucht.


    Es ergibt kein Erfolg, ich bekomme mit Benutzer und Passwort keine Verbindung zur Freigabe, über Windows.


    Wenn ich die Freigabe "öffentlich" und mit Zugriff " alle: lesen/schreiben/ausführen " erstelle, funktioniert alles problemlos. Sobald ich aber einen Benutzer anlege ihm den Zugriff erteile kommt in Windows ein Login und dann die Meldung:


    ....... Kann nicht zugegriffen werden eventuell Haben Sie keine Berechtigung......




    System:


    OMV - 2020 neu aufgesetzt, aktuelle Version 5.6.16-1 Usul

    Systemspeicher - CFast

    Datenspeicher - RAID5



    Datenspeicherstruktur:


    Unter /srv= dev-disk-by-label-StorageR5

    Darunter gibt es einen Hauptordner - "Datenspeicher"

    Dann kommen darin viele Unterordner Bsp. "Multimedia" usw......



    Mein Anlegen eines Benutzers + Freigabe + SMB-Freigabe (hier als Beispiel User=andi)


    1.0 Benutzer:

    Name= andi Gruppe= users Passwort= andi Prvilegien= lesen/schreiben/ausführen Heimverzeichnis= aus


    2.0 Freigegebene Ordner:

    2.1 Freigegebene Ordner= "Datenspeicher"

    2.2 Priviliegien= lesen/schreiben/ausführen (ACL nichts geändert)


    3.0 SMB/CIFS

    3.1 Einstellungen: Aktivieren= ja WORKGROUP Durchsuchbar= ja Asynchrones I/O= ja

    3.2 Freigaben: Aktivieren= ja Freigabe= "Datenspeicher" Öffentlich: nein nur lesen= nein Durchsuchbar= ja Erbe ACL's= ja


    Dann: /# systemctl restart smbd.service


    so sieht eine meiner freigaben aus. Natürlich habe ich viele viele male andere Einstellungen probiert auch das setzen von ACL's.

    Immer wieder ein "reset permissions"........




    Ein wenig davon was ich schon probiert/angesehen habe:


    neuen User und neue Gruppe erstellt

    Neuen Hauptordner also neben dem "Datenspeicher" nochmal eine neue Freigabe

    reset Permissions und dann wieder alles neu gemacht

    .....

    ........


    1. ACL's - mit und ohne (rekursiv)
    2. Neustart - von Windows/OMV/smbd.service (nach Änderungen, bevor ich alles mehrmals neu angelegt hatte usw....)
    3. Windows - mit 7 und 10 die Zugriffe per Netzwerk & Netzlaufwerkverbindungen versucht.

    4. Windows: Hier unter "Get-SmbServerConfiguration"

    EnableSecuritySignature : False

    EnableSMB1Protocol : True

    EnableSMB2Protocol : True

    EnableStrictNameChecking : True

    EncryptData : False


    Testweise unter: Lokale Sicherheitsrichtlinien / Loakale Richtlinien / Sicherheitsoptionen / Netzwerksicherheit:

    Den Lan Manager-Authenfizierungsebene auf "Nur NTLMv2-Antworten senden. LM & NTLM verweigern" gesetzt.


    Da aber öffentliche Freigaben funktionieren nur eben die besagten mit user und Passwort nicht........ Oh man



    5. OMV

    Per SFTP mit einem Datei-Explorer die Zugriffswerte des Volumes geändert:

    Also= „dev-disk-by-label-StorageR5“ wo der Hauptordner: „Datenspeicher“ enthalten ist.


    zum testen, ist hier aktuell:


    &thumbnail=1

    Was ist hier bei den dev-disk eigentlich der Standard?




    So, da ich jetzt einiges umgestellt habe, sieht aktuell alles wie folgt aus:


    /# ls -l /srv/

    insgesamt 20

    drwxrwsr-x 4 root users 4096 Okt 16 19:06 dev-disk-by-label-StorageR5

    drwxr-xr-x 4 root root 4096 Okt 16 19:07 dev-disk-by-uuid-xxxxxxxxxxxxxxx

    drwxr-xr-x 2 ftp nogroup 4096 Mär 10 2020 ftp

    drwxr-xr-x 3 root root 4096 Sep 30 20:55 pillar

    drwxr-xr-x 6 root root 4096 Sep 30 20:55 salt



    /# ls -l /srv/dev-disk-by-label-StorageR5/

    insgesamt 40

    -rw------- 1 root users 6144 Okt 16 19:07 aquota.group

    -rw------- 1 root users 7168 Okt 16 19:07 aquota.user

    drwx------ 2 root users 16384 Mär 10 2020 lost+found

    drwxrws---+ 14 root users 4096 Okt 15 22:45 "Datenspeicher"



    /# systemctl status smbd.service

    smbd.service - Samba SMB Daemon

    Loaded: loaded (/lib/systemd/system/smbd.service; enabled; vendor preset: enabled)

    Active: active (running) since Sat 2021-10-16 20:06:59 CEST; 28min ago

    Docs: man:smbd(8)

    man:samba(7)

    man:smb.conf(5)

    Process: 16341 ExecStartPre=/usr/share/samba/update-apparmor-samba-profile (code=exited, status=0/SUCCESS)

    Main PID: 16351 (smbd)

    Status: "smbd: ready to serve connections..."

    Tasks: 5 (limit: 4915)

    Memory: 7.7M

    CGroup: /system.slice/smbd.service

    ├─16351 /usr/sbin/smbd --foreground --no-process-group

    ├─16354 /usr/sbin/smbd --foreground --no-process-group

    ├─16355 /usr/sbin/smbd --foreground --no-process-group

    ├─16378 /usr/sbin/smbd --foreground --no-process-group

    └─16380 /usr/sbin/smbd --foreground --no-process-group


    Okt 16 20:22:31 (Server) smbd[16380]: [2021/10/16 20:22:31.160713, 1] ../source3/smbd/service.c:529(make_connection_snum)

    Okt 16 20:22:31 (Server) smbd[16380]: create_connection_session_info failed: NT_STATUS_ACCESS_DENIED

    Okt 16 20:22:31 (Server) smbd[16380]: [2021/10/16 20:22:31.206739, 1] ../source3/smbd/service.c:346(create_connection_session_info)

    Okt 16 20:22:31 (Server) smbd[16380]: create_connection_session_info: guest user (from session setup) not permitted to access this share (XYZ)

    Okt 16 20:22:31 (Server) smbd[16380]: [2021/10/16 20:22:31.206844, 1] ../source3/smbd/service.c:529(make_connection_snum)

    Okt 16 20:22:31 (Server) smbd[16380]: create_connection_session_info failed: NT_STATUS_ACCESS_DENIED

    Okt 16 20:22:31 (Server) smbd[16380]: [2021/10/16 20:22:31.209714, 1] ../source3/smbd/service.c:346(create_connection_session_info)

    Okt 16 20:22:31 (Server) smbd[16380]: create_connection_session_info: guest user (from session setup) not permitted to access this share (XYZ)

    Okt 16 20:22:31 (Server) smbd[16380]: [2021/10/16 20:22:31.209803, 1] ../source3/smbd/service.c:529(make_connection_snum)

    Okt 16 20:22:31 (Server) smbd[16380]: create_connection_session_info failed: NT_STATUS_ACCESS_DENIED




    /# nano \etc\samba\smb.conf

    global]

    workgroup = WORKGROUP

    server string = %h server

    dns proxy = no

    log level = 1

    log file = /var/log/samba/log.%m

    max log size = 1000

    logging = syslog

    panic action = /usr/share/samba/panic-action %d

    encrypt passwords = true

    passdb backend = tdbsam

    obey pam restrictions = no

    unix password sync = no

    passwd program = /usr/bin/passwd %u

    passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .

    pam password change = yes

    socket options = TCP_NODELAY IPTOS_LOWDELAY

    guest account = nobody

    load printers = no

    disable spoolss = yes

    printing = bsd

    printcap name = /dev/null

    unix extensions = yes

    wide links = no

    create mask = 0777

    directory mask = 0777

    map to guest = Bad User

    use sendfile = yes

    aio read size = 16384

    aio write size = 16384

    time server = no

    wins support = no

    multicast dns register = no

    # Special configuration for Apple's Time Machine

    fruit:aapl = yes

    #======================= Share Definitions =======================

    [Datenspeicher]

    path = /srv/dev-disk-by-label-StorageR5/"Datenspeicher"/

    guest ok = yes

    guest only = no

    read only = no

    browseable = yes

    inherit acls = yes

    inherit permissions = no

    ea support = no

    store dos attributes = no

    vfs objects =

    printable = no

    create mask = 0664

    force create mode = 0664

    directory mask = 0775

    force directory mode = 0775

    hide special files = yes

    follow symlinks = yes

    hide dot files = yes

    read list =

    write list = "andi"


    Wie beschrieben, wenn ich bei der Freigabe auf öffentlich stelle funktioniert alles. Sobald ich einen User/Gruppe anlege geht nichts mehr.

    :cursing:8|;(




    Ich bekomme es einfach nicht hin und weiß nicht mehr weiter. Habe das www natürlich mehrmals schon durchforstet....


    Wäre echt super, wenn mir hier jemand weiterhelfen könnte. ;)

    Beste Grüße

  • Agricola

    Approved the thread.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!