Need help with KVM and TPM: error when I compile swtpm

  • So; for Windows 11, it will be a mandatory to have a TPM module

    under KVM it is possible to emulate a TPM module


    Apparently under the RedHat family, it is just a matter of installing the right package SWTPM

    under Debian/OMV I tried by installing tpm-tools and/or tpm2-tools but both end with an error that SWTPM is missing in PATH.


    so I found that project (https://github.com/stefanberge…deb-package-ubuntu-debian) which seams to be the solution, but I'm not a good compiler guy

    even after installing yelp-tools for m4; the compilation of swtpm fail

    here what I tried

    Code
    apt -y install git dpkg-dev debhelper libssl-dev libtool net-tools libfuse-dev libglib2.0-dev libgmp-dev expect libtasn1-dev socat python3-twisted gnutls-dev gnutls-bin libjson-glib-dev python3-setuptools softhsm2 libseccomp-dev yelp-tools
    cd /tmp
    git clone https://github.com/stefanberger/swtpm.git
    cd swtpm
    dpkg-buildpackage -us -uc -j$(nproc) -d

    the error

    Code
    configure: exit 1
    dh_auto_configure: ./configure --build=x86_64-linux-gnu --prefix=/usr --includedir=\${prefix}/include --mandir=\${prefix}/share/man --infodir=\${prefix}/share/info --sysconfdir=/etc --localstatedir=/var --disable-silent-rules --libdir=\${prefix}/lib/x86_64-linux-gnu --libexecdir=\${prefix}/lib/x86_64-linux-gnu --disable-maintainer-mode --disable-dependency-tracking --with-openssl --with-gnutls --without-cuse returned exit code 1
    make[1]: *** [debian/rules:8: override_dh_auto_configure] Error 2
    make[1]: Leaving directory '/tmp/swtpm'
    make: *** [debian/rules:4: binary] Error 2
    dpkg-buildpackage: error: debian/rules binary subprocess returned exit status 2

    does anybody have an idea on how to fix that ?

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!