Error installing OMV6 on Armbian Bullseye (php-pam : Depends: phpapi-20180731 but it is not installable)

  • Hi,


    I'm installing OMV6 on Armbian Bullseye on an OrangePi One Plus.


    I followed these command line instructions here:


    https://openmediavault.readthe…stallation/on_debian.html


    I was able to install succesfully on an Odroid HC4, but the OrangePi is generating an error on this command:


    Code
    apt-get --yes --auto-remove --show-upgraded \
    --allow-downgrades --allow-change-held-packages \
    --no-install-recommends \
    --option DPkg::Options::="--force-confdef" \
    --option DPkg::Options::="--force-confold" \
    install openmediavault-keyring openmediavault

    Results in the following error:


    Code
    The following packages have unmet dependencies:
     php-pam : Depends: phpapi-20180731 but it is not installable
    E: Unable to correct problems, you have held broken packages.

    I've looked through the forums and on Github and can't find anything to help me here.


    It seems the missing package is a Debian Buster package, but isn't available in Bullseye.


    Any suggestions?

  • geaves

    Approved the thread.
  • The documentation is primarily for amd64, that is why there is a reference to the Raspberry Pi, as that is an SBC, the OrangePi is an SBC so the guide I pointed to is the only way to install OMV in your user case.

    Raid is not a backup! Would you go skydiving without a parachute?

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!