Error message while trying to login to web interface

  • I'm running OMV on my Raspberry Pi since 2020. After a blackout the clock was wrong so I decided to correct it via SSH. I installed ntp and a few minutes later the clock was fixed.

    For whatever reason I executed

    sudo apt autoremove

    which removed OMV =O I tried to re-install it with

    wget -O - | sudo bash

    which worked quite well. The web server and Samba is up again, but unfortunately I cannot login to the web interface.

    After entering user name and password it takes a few seconds and then I get

    Error #0:
    OMV\Rpc\Exception: Failed to connect to socket: No such file or directory in /usr/share/php/openmediavault/rpc/
    Stack trace:
    #0 /var/www/openmediavault/rpc/ OMV\Rpc\Rpc::call('UserMgmt', 'authUser', Array, Array, 2, true)
    #1 [internal function]: OMVRpcServiceSession->login(Array, Array)
    #2 /usr/share/php/openmediavault/rpc/ call_user_func_array(Array, Array)
    #3 /usr/share/php/openmediavault/rpc/ OMV\Rpc\ServiceAbstract->callMethod('login', Array, Array)
    #4 /usr/share/php/openmediavault/rpc/proxy/ OMV\Rpc\Rpc::call('Session', 'login', Array, Array, 3)
    #5 /var/www/openmediavault/rpc.php(45): OMV\Rpc\Proxy\Json->handle()
    #6 {main}

    I'm not sure which OMV version I was running before I removed it accidentally, but I'm quite sure it was version 5, maybe a pre-release, I cannot remember anymore. I think I made some kind of upgrade with my attempt to re-install OMV, but now I'm stuck.

    Here's a list of installed OMV packages, maybe it helps:

    dpkg -l | grep openmediavault
    iU  openmediavault                       5.6.16-1                            all          openmediavault - The open network attached storage solution
    rc  openmediavault-flashmemory           5.0.7                               all          folder2ram plugin for OpenMediaVault
    ii  openmediavault-keyring               1.0                                 all          GnuPG archive keys of the OpenMediaVault archive
    rc  openmediavault-omvextrasorg          5.2.3                               all Package Repositories for OpenMediaVault

    I don't want to uninstall packages indiscriminately, I end up making the situation even worse.

    Additionally I noticed an issue with lvm2:

    I have considered deleting lvm2 completely and reinstalling it, but it says it will also remove the openmediavault package, therefore i have discarded this plan for the time being.

  • Actually I have a backup of my SD card. Unfortunately it's some months old and I've changed a lot of things on OMV and file system level in the last weeks, which I want to avoid to re-apply, if possible.

    Reinstalling OMV via apt doesn't work:

    Any suggestions?

    If there's no way to fix the issue, can I somehow save the current configuration (e.g. via SSH)? I think it's still there, as I can access my Samba shares and the cronjobs also work as expected. If not, where are the cronjobs stored? I tried "crontab -l" for various users, but all seem to be empty.

  • You have to remove ntp and then try again to install omv with the script.

    ntp wasn't installed (anymore), for whatever reason. Re-installation via script hasn't fixed the issue.

    However, in the end I was able to fix it. I used sudo apt purge lvm2 to fix my "broken" apt, which also removed all openmediavault packages.

    Then I installed OMV again via

    wget -O - | sudo bash

    and I'm now able to login again. My configuration is also still there, thanks guys 8):thumbup:

  • macom

    Added the Label OMV 5.x
  • macom

    Added the Label resolved

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!