No whitespaces allowed in the name of shared folder

  • Hi everyone,


    I'm moving my old NAS storage to a newer one powered with OMV and realized I can't put a whitespace symbol in shared folder name. That's weird, I've spend some time and found there is no limitation to this symbol neither from Samba, nor FTP, nor NFS.

    What I did:

    1) connected server via ssh, edited /etc/samba/smb.conf and put a whitespace to section name (eg [ShareName] => [Share Name]) and restarted smb service. Tested OK, but the config was rewritten automatically later, of course. So, samba itself supports it as expected.
    2) Then I tried to mess with JS that is filtering out symbols from fields but had no luck there.
    3) edited /etc/openmediavault/config.xml via ssh (<name>ShareName</name> => <name>Share Name</name>) and applied settings via webpaned. Viola! Now we're talking - I see a name with whitespace in the panel, can add this share to SMB service and it's testing good and consistent after reboots or other settings changes.


    So, again, I see no reasons to filter out whitespace. It's not required by protocols, and system is actually working stable so far after some little filthy hacking. It's just limited by input field's processing at the web control panel.


    Please don't advise to use dashes or underscore - I have clients with fixed path strings and that's out of my control. I need to replace NAS server transparently for them - same name, same paths.

    Let me know if any details are needed. My OMV's version is 5.6.16-1 (Usul), running on x86_64 ESXi. Thanks!

  • votdev

    Added the Label resolved
  • It is how it is, I don’t have to discuss this with you. Please accept how OMV handles this or choose a other software because OMV does not fit your requirements.


    You can be sure that this would have been implemented already if there are no strong reasons against this feature.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!