Error #3008

  • I've did some changes in shares in the following files /usr/share/openmediavault/templates/config.xml and /etc/openmediavault/config.xml but before the change i did an cp from the original files. But after the reboot there's an error so the webgui isn't accessible:

    Error #3008:
    exception 'OMVException' with message 'Failed to load configuration (Warning 1549: failed to load external entity "/etc/openmediavault/config.xml" (line=0, column=0))' in /usr/share/php/openmediavault/
    Stack trace:
    #0 /usr/share/php/openmediavault/ require_once()
    #1 /var/www/openmediavault/index.php(23): require_once('/usr/share/php/...')
    #2 {main}

    After the error i've deleted the config files and replaced them with the copy, and did an reboot but still the same error occurs. But the running services are working fine, how can i solve this without reinstalling the whole server. :?

  • Try this:

    cp /etc/openmediavault/config.xml.bak /etc/openmediavault/config.xml

    if it asks you if it is ok to replace say yes.

    You should not mess with these xml files without consulting the mods on forum first.

  • This is not working either, i know that i should nog change the config.xml but i've got an hard time to delete an share. But before i did an copy of the original config file, so i thought that i was save to change several things and do an rollback if necessary.
    Is there an way so retrieve which specific item fails in the config file?

  • I've changed the mail notification adres and password, and the user and share names.
    What i've done is create folder data11 to create an FTP share, and accidentally enabled user home directory.
    Then i've disabled data11 and tried to disable user home directory, that was not working so i've tried to delete the share data11 in the config file and disable home directories, after this the error occurs and replacing with the old file wont help.

    EDIT: i can't put the config file because of message limit and wont able to add this as an attachment.

  • Quote from "tekkbebe"

    Don't want it as an attachment. Did you try code box????

    Yes Your message contains 67992 characters. The maximum number of allowed characters is 60000.

  • In part 2 data11 is still there:

    I would delete the user that you made that their home directory 1st. Then delete that shared folder section of the xml.

  • That's correct because i did an rollback of the config.xml file, the data isn't deleted. My goal is to get the webgui working and then retrying to disable home dir and deleting the share and data.

  • Quote from "tekkbebe"

    This is a mess if you used that user in all the other shares.

    I wanted to use this user for FTP to, but that shouldn't be the issue why the webgui is broken? I've changed nothing with the user permissions.
    I think it is the home directory, if i disable this can i safely remove the data11 share and data?

  • Quote from "tekkbebe"

    For the life of me I can't figure out why you messed with this file:


    I've checked the file and didn't change anything, ive installed OMV in an VM its original. So i only did an copy, why i dont know. :roll:

    But i can conclude the config.xml is fixable?

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!