Share is read/write from Windows, but "Permission Denied" from Linux

  • I just installed OMV and have everything configured and working properly (I thought). I can access files from all my Windows devices. I can even write to the share - create folders, copy files & folders.


    On my Linux box (Ubuntu Mint), I can see the folders & files and I can open them. However, when I try to copy files from my Mint box, I get "Permission Denied". I checked the settings for the OMV and the share is set to "Guest Allowed", the Read Only option is off, the Browseable is on.


    I have no idea why I can read/write from the Windows machines (I tried 3 different ones), but not from Linux. I am using SMB/CIFS.:(

  • This is a home network NAS, so can't I leave it open? The Windows users log in as "guest" so they don't have to enter username and password. Is the Linux configuration different (sorry, sort of new to Linux)

  • Are you mounting the smb share via mount -t cifs ... or are you trying to write to a directory on /srv/dev-by... manually?

    If you got help in the forum and want to give something back to the project click here and write up your solution for others.

  • ZOKI - Not sure if this tells you what you want, but I used Nemo, clicked on NETWORK and OMV (server name) was there. I expanded that and saw the share name DATA (real original, I know). When I open that folder, I can see all the files in the folder and I can open them. But when I try to copy files from my PC, it says "access denied".


    I did also notice that there are two other folders in NETWORK - "omv - SMB/CIFS" and "omv - SSH". The "omv - SMB/CIFS" structure is the same as the OMV folder. Should I be using that one instead? Any ideas why there may be two folders (I can understand the "omv - SSH"?

  • I do not know what nemo is doing, but make sure that the share is mounted with the right permissions on the Linux Mint side.


    from the command line it would be something like

    sudo mount -t cifs -o user=your_user,dir_mode=0755,file_mode=0755 //YOUR_OMV_SERVER/YOUR_SHARW /mnt/YOUR_MOUNT_POINT


    Setting dir_mode and file_mode might do the trick.



    If you got help in the forum and want to give something back to the project click here and write up your solution for others.

  • Sorry for the delay, Zoki. I came in one day and it worked. Next day, it didn't.


    I installed the same version of Linux (Linux Mint Cinnamon) on PC-B and it works without a problem and has been working for several days. I didn't really have to set anything up on the PC-B and it worked without issue. So would I be right in thinking it must be a configuration issue on PC-A that keeps it from working?

  • Yes, it is on the mounting PC, not OMV.


    Did you try to mount manually and check that?

    If you got help in the forum and want to give something back to the project click here and write up your solution for others.

  • Yes. It did not help. I agree that this looks like a problem with the mounting PC and not OMV.


    I am going to try posting this on the Linux Mint forum and see if they have a solution.


    Thanks for your help.:thumbup:

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!