I think I screwed up my SMB/CIFS

  • Problem

    When I try to disable SMB or alter it through the WebUI I get the attached logs


    What I want to do

    "Reset" my SMB configuration so I can start fresh. Is there a command to do this? Can it be done through the WebUI?


    Last resort

    Reinstall OMV... again... please let me know if what I want to do is not possible, and I will go ahead an reinstall right away.


    Have tried

    • going over <mntent> for duplicate/incorrect entries in /etc/openmediavault/config.xml (none found)
    • sudo apt-get install --reinstall samba (see post below)
    • reboot
    • apt list --upgradable (none)
    • service samba status
      Produces: Unit samba.service could not be found.
    • systemctl start smbd.servicesystemctl status smbd.servicejournalctl -xe
  • > sudo apt-get install --reinstall samba

    No change to SMB in the WebUI

  • systemctl start smbd.service

    systemctl status smbd.service

    journalctl -xe

  • I've been searching and reading and could it be that my error is somehow caused by a line in a Python script being out of range?


    As in allowed value is 0, 1, or 2 but the value has somehow been altered to 3 or higher? Anyone familiar with this?


    My post hasn't garnered much response in the two days it's been up, so I'm beginning to lean towards the reality that there's no way to just "reset" SMB/CIFS to "factory". I don't think the fault lies with OMV - I think it lies with my self and SAMBA, as it's not really user friendly.


    Thanks for taking a look at my post and my log - I'll be reinstalling OMV in the weekend.

  • I think, it is a problem with the OMV config. The scripts are looking for an entry in /etc/openmediavault/config.xml like //system/fstab/mntent[uuid='ae6b19f1-53f7-4a2e-88aa-5ffbb878f7c0'


    Maybe it helps to check with xmlstarlet sel -t -c "//system/fstab/mntent" /etc/openmediavault/config.xml

    and compare to cat /etc/fstab

  • Hey Zoki thanks for replying.


    This is the outputs

    xmlstarlet sel -t -c "//system/fstab/mntent" /etc/openmediavault/config.xml

    Code
    <mntent>
    <uuid>dbe0333b-99b5-4f8a-be72-e7695b776806</uuid>
    <fsname>/dev/disk/by-uuid/5e2c0c41-f93a-4bf3-b3a6-6eb399826835</fsname>
    <dir>/srv/dev-disk-by-uuid-5e2c0c41-f93a-4bf3-b3a6-6eb399826835</dir>
    <type>ext4</type>
    <opts>defaults,nofail,user_xattr,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0,acl</opts>
    <freq>0</freq>
    <passno>2</passno>
    <hidden>0</hidden>

    cat /etc/fstab

    I can't see any difference in the two of them.

  • The error message is:

    Code
    penmediavault.config.database.DatabaseQueryNotFoundException: No such object: //system/fstab/mntent[uuid='ae6b19f1-53f7-4a2e-88aa-5ffbb878f7c0']


    Something expects to find a filesystem with the given UUID, but none is there.


    to find out what this might be try grep -C 4 ae6b19f1-53f7-4a2e-88aa-5ffbb878f7c0 /etc/openmediavault/config.xml to find the pace which references the missing filesystem.


    I expect it to be somwhre in the SMB config.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!