Chronyd and Chrony services failed to start

  • Hello, I'm having issues with these two services on my server, from cockpit they are shown as failed and if I try to start them always the same error is shown:

    I have time issues at every restart there are about 11 minutes of time difference. I have to input the time manually every time otherwise my docker containers using 2FA start throwing errors due to time differences. I've tried restarting the service manually but I always get the same output. Any ideas to fix it?

  • RTC Battery empty?

    omv 6.0.8 (Shaitan) on RPi CM4/4GB with 64bit Kernel 5.10.63

    2x 6TB 3.5'' HDDs formatted with ext4 via 2port PCIe SATA card with ASM1061R chipset providing hardware supported RAID1


    omv 5.6.21-1 (usul) on RPi4/4GB with Kernel 5.10.63 and WittyPi 3 V2 RTC HAT

    2x 3TB 3.5'' HDDs formatted with ext4 in Icy Box IB-RD3662-C31 / hardware supported RAID1

    For Read/Write performance of SMB shares hosted on this hardware see forum here

  • I have time issues at every restart there are about 11 minutes of time difference.

    Since you don't say what server you have, we can only speculate!!!!

    RTC Battery empty?

    Or maybe an SBC without RTC?

  • We had to ask, there's no crystal ball on this side of the screen.


    Moving on, do you have this configured:

  • Yes obviously, I made the mistake of forgetting to specify it.


    I have them setup as Europe/Rome and I am using time.cloudflare.com

    It will always depend if you already have network or not to sync the time.

    Or try changing it with the pool.ntp.org

    I have to input the time manually every time otherwise my docker containers using 2FA start throwing errors due to time differences.

    Maybe you can delay the start of docker until you have the time synched.


    Some expertise advice will be needed here but (probably) can be added to the docker.service a:

    Execute...=depends on chrony (just guessing)

  • I've tried to add pool.ntp.org but the result is the same. And if I try to restart manually the service every time the same error posted at the beginning is logged.

    Sorry but I've reached the top of what I know on this matter.


    Hope someone with fresh ideas can come up with a different approach/solution.

  • Here it is the output of the commands requested. systemctl restart chrony returns to terminal without output

  • Dec 04 10:03:01 Server chronyd[14983]: Selected source 192.168.178.1

    This doesn't seem right!!!!!


    Code
    pi@tacho:~ $ sudo systemctl status chrony
    ● chrony.service - chrony, an NTP client/server
    Loaded: loaded (/lib/systemd/system/chrony.service; enabled; vendor preset: enabled)
    Active: active (running) since Sat 2021-12-04 09:32:18 WET; 3min 18s ago
    ............
    Dec 04 09:32:18 tacho systemd[1]: Started chrony, an NTP client/server.
    Dec 04 09:32:24 tacho chronyd[199632]: Selected source 130.60.204.10 (pool.ntp.org)



    Maybe disable and re-enable from the OMV gui?!?

  • Could you please post the output of systemctl status systemd-timesyncd

    Code
    ● systemd-timesyncd.service - Network Time Synchronization
    Loaded: loaded (/lib/systemd/system/systemd-timesyncd.service; enabled; vendor preset: enabled)
    Drop-In: /usr/lib/systemd/system/systemd-timesyncd.service.d
    └─disable-with-time-daemon.conf
    Active: inactive (dead)
    Docs: man:systemd-timesyncd.service(8)
  • This doesn't seem right!!!!!


    Code
    pi@tacho:~ $ sudo systemctl status chrony
    ● chrony.service - chrony, an NTP client/server
    Loaded: loaded (/lib/systemd/system/chrony.service; enabled; vendor preset: enabled)
    Active: active (running) since Sat 2021-12-04 09:32:18 WET; 3min 18s ago
    ............
    Dec 04 09:32:18 tacho systemd[1]: Started chrony, an NTP client/server.
    Dec 04 09:32:24 tacho chronyd[199632]: Selected source 130.60.204.10 (pool.ntp.org)



    Maybe disable and re-enable from the OMV gui?!?

    I have my router acting as time server, I have tried disabling this option and then it uses an external server but the result is exactly the same

  • I have my router acting as time server, I have tried disabling this option and then it uses an external server but the result is exactly the same

    On the gui, what happens if you use 192.168.178.1 instead of pool.ntp.org


    Also, just for comparing (with the pool.ntp.org):

    Code
    pi@tacho:~ $ sudo systemctl status systemd-timesyncd
    ● systemd-timesyncd.service
    Loaded: masked (Reason: Unit systemd-timesyncd.service is masked.)
    Active: inactive (dead)


    Try to stop timesynced and then start chrony:

    systemctl stop systemd-timesyncd

    systemctl disable systemd-timesyncd


    systemctl restart chrony

    systemctl status chrony


  • I chose 192.168.178.1 in the GUI and this is the output of sudo systemctl status systemd-timesyncd


    Code
    ● systemd-timesyncd.service - Network Time Synchronization
    Loaded: loaded (/lib/systemd/system/systemd-timesyncd.service; enabled; vendor preset: enabled)
    Drop-In: /usr/lib/systemd/system/systemd-timesyncd.service.d
    └─disable-with-time-daemon.conf
    Active: inactive (dead)
    Docs: man:systemd-timesyncd.service(8)

    Executed the commands that you suggested and the output of the last command is:


Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!