RAID reshaping stuck (4->5)

  • Hello everyone,


    I tried adding one more hard drive to my existing RAID arry through the webgui as usual. The reshaping process begun 24 hrs ago and is still stuck at 56% with writing speed close of 100k/sec and CPU 2 at 100%.

    I tried rebooting but it didn't change a thing.

    mdadm --detail /dev/md127 is saying the reshaping is at 56%

    cat /proc/mdstat show reshaping still in progress at 100k/sec


    There doesn't seem to be anything wrong in the logs.


    Any help would be appreciated

    OMV 5.X with OMV-Extra on a Proxmox 6 Server

  • notarobot

    Added the Label OMV 5.x
  • Can you list outputs from configuration


    Do you have mission critical services running such that restart of services and raid an issue? (aka what suggestions that impact data can be made)


    # root cause a bit before restart

    lsblk

    mdadm -D /dev/md0

    cat /proc/mdstat


    # restart if this is option Ex: 4 drives in R5

    mdadm --stop /dev/md0

    mdadm --assemble --run --force --update=resync /dev/md0 /dev/sdb /dev/sdc /dev/sdd /dev/sde


    # Post above output of "tail -f /var/log/syslog" while doing above in seperate shell

    tail -f /var/log/syslog


    Lets see if something shows its head as issue


    PS: What are disk drive size... do you KNOW they are good drives

    Nerd looking for better coffee

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!