Accessing my OMV nas server outside the house

  • Hey guys. I want my NAS to be reachable from outside my network. Actually, I just want to be able to use the nzb360 app with radar/sonarr/bazarr outside my local network. I've installed duckdns via docker, also Nginx proxy manager. I have an Duckdns account, and I have created a new domain there. When I start the Nginx proxy manager I go to add new proxy hosts. When I click the Save button I get an error "Internal error". This is if I select to create a new SSL certificate. I have ports 443 and 8888 forwarded. If I go to that duckdns domain and add for example 7878 port for radarr, the page opens, so that's good. I just need to add SSL to it. I founds some logs and they are something like this:


    Code
    Error: Command failed: certbot certonly --config "/etc/letsencrypt.ini" --cert-name "npm-7" --agree-tos --authenticator webroot --email "marjan@gmail.com" --preferred-challenges "dns,http" --domains "marjan-mynas.duckdns.org" Saving debug log to /var/log/letsencrypt/letsencrypt.log
    Some challenges have failed.
    Ask for help or search for solutions at https://community.letsencrypt.org. See the logfile /var/log/letsencrypt/letsencrypt.log or re-run Certbot with -v for more details.
        at ChildProcess.exithandler (child_process.js:308:12)    at ChildProcess.emit (events.js:314:20)    at maybeClose (internal/child_process.js:1022:16)    at Process.ChildProcess._handle.onexit (internal/child_process.js:287:5)


    Now one more question. Do I need all of this, just to access my arr's via nzb360 app?? If not, I will just give up, it's too complicated.

  • Did you configure your router to forward port 80 and 443 to your OMV server


    Router:80 -> OMV:8080

    Router:443 -> OMV:8443


    make the nginx-proxy-manager listen to port 8080 and 8443(port 80 and 443 are used by OMV, if you did not change that):

    Code
        ports:
          # These ports are in format <host-port>:<container-port>
          - '8080:80' # Public HTTP Port
          - '8443:443' # Public HTTPS Port
          - '81:81' # Admin Web Port


    In nginx-proxy-manager configure a proxy for ip of omv host port 7878


    Close the port 7878 on your router, so the traffic goes that was:

    internet -port 80 or 443 > your router -> port 8080 or 8443 nginx-proxy-manager -> port 7878 nzb360 container


    This example assumes, you are not using ports 8080 and 8443 on your omv server and you did not follow the Best Practice: Use a Docker network


    Check is you can browse to ip_of_omv:8080 and ip_of_omv:8443


    Others here recommend linuxserver.io/swag as proxy, you might get more help with that here (i use traefik and can help with that).

    If you got help in the forum and want to give something back to the project click here (omv) or here (scroll down) (plugins) and write up your solution for others.

  • yes, looks good. Do you have it running with the dns name given above in the error message?

    If you got help in the forum and want to give something back to the project click here (omv) or here (scroll down) (plugins) and write up your solution for others.

  • The code in post #1 displays an gmail address and a duckdns dns name. I tried it, but there is no ip given for it.


    The config is the other way round:

    host 8080 -> container 80

    host 8443 -> container 443

    host 81 -> container 81

    If you got help in the forum and want to give something back to the project click here (omv) or here (scroll down) (plugins) and write up your solution for others.

  • OK, I will give it a shot this way. But why does it need port 80 opened, when we assign that to a container, and not the host machine?


    EDIT: Yeah, I don't get that error for the port anymore, but I still get the "Internal error" in the ngnix dashboard.

  • Traffic flows like i said above:


    internet -> port 80 on your router -> port 8080 on your omv server -> port 80 in the container


    Same for 443.


    You need to open 80 and 443 on your router, because this is the http(s) standard.

    You can not use 80 and 443 on the host, so we need something different. -> 8080 / 8443

    Inside the container the program is listening to 80 / 443 (as it is the stanard) so we need to connect 8080 to 80 and 8443 to 443


    only a small detour.

    If you got help in the forum and want to give something back to the project click here (omv) or here (scroll down) (plugins) and write up your solution for others.

  • Got it! But I still have this error from the first post. :(


    BTW, when I check on port checker websites, the port 80 is opened, the port 443 is not. I don't know why, maybe 443 is not used at the moment. But I've used the same method to open them.

  • If you allow me to interrupt ... I have not read the whole thread, but this solution may be simpler.

    [How-To] Install Wireguard (VPN) in docker, server mode

    Could be an option, if you want to access it from well known trusted devices.


    Let's get it working and than make a decision of what to use.


    Check the log of the container Portainer -> Containers -> Paper symbol of the container.

    If you got help in the forum and want to give something back to the project click here (omv) or here (scroll down) (plugins) and write up your solution for others.

  • Here you go:


  • Your router is not configured properly. When I connect, I get the OMV interface, which should not be there.

    But at least you changed the default password.


    In Post #3 you only showed the config for 443, not 80. Is it configured too?

    If you got help in the forum and want to give something back to the project click here (omv) or here (scroll down) (plugins) and write up your solution for others.

  • You ae forwarding port 80 coming from the internet to port 80 of the server, the same for 443.

    80 should take the detour to 808 and 443 shouldtake the detour to 8443. You did not show the headers of the table, so i can not tell you which port is wrong.

    If you got help in the forum and want to give something back to the project click here (omv) or here (scroll down) (plugins) and write up your solution for others.

  • If your router is a TP-Link, configure it like this:

    Service Port: 80

    Internal Port 8080

    IP. IP of the OMV



    and


    Service Port 443

    Internal Port 8443

    IP: IP of OMV

    If you got help in the forum and want to give something back to the project click here (omv) or here (scroll down) (plugins) and write up your solution for others.

  • Another thing:


    No need to change the duckdns name every time you post it. Every DNS name gets attacked., bots check for new names in DNS all the time.

    If you got help in the forum and want to give something back to the project click here (omv) or here (scroll down) (plugins) and write up your solution for others.

  • Headers of the port assignment i nthe router have not been visable in the first try. Now i have everyting i need:



    If you got help in the forum and want to give something back to the project click here (omv) or here (scroll down) (plugins) and write up your solution for others.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!