Accessing my OMV nas server outside the house

  • Take any which is free. You have to change on both sides: Router and the container (host port!).

    If you got help in the forum and want to give something back to the project click here (omv) or here (scroll down) (plugins) and write up your solution for others.

  • The network looks ok now. Can you provide the logs of the container?


    try connectiong to https://<my_duckdns_name>/ and see what you get.
    do the same with http://<my_duckdns_name>/


    You should see something.

    If you got help in the forum and want to give something back to the project click here (omv) or here (scroll down) (plugins) and write up your solution for others.

  • In both cases I get error connection refused. Because the port 80 is closed. But when I go to my router and change both those fields to 80 (now one is 8888 like you said), then the port opens and I can access my OMV via http and get an error on https.

  • Maybe I'm missing something here, but if you're using duckdns, and you're using the Linuxserver containers of sonarr, etc... Just use linuxserver/swag and reverse proxy them through it, and don't use nginx-proxy-manager.


    This is literally a 5sec set up for almost any service once you have duckdns routing through swag properly.

  • But even swag needs the ports be to right. In the whole thread we have not looked into nginx-proxy but tried to get ports right.


    Nabukodonosor if you switch to swag, you have to change the scheme how you use your dns names. You need a subdomaon for each service.

    If you got help in the forum and want to give something back to the project click here (omv) or here (scroll down) (plugins) and write up your solution for others.

  • But even swag needs the ports be to right. In the whole thread we have not looked into nginx-proxy but tried to get ports right.


    Nabukodonosor if you switch to swag, you have to change the scheme how you use your dns names. You need a subdomaon for each service.

    Correct.


    As for the subdomains... you do but it doesn't really change anything on the part of the end user.. If you set swag to wildcard on subdomains (which is generally recommended).. then you copy your service.subdomain.conf file from the examples in the swag config.... Then all you have to do is put your container on the swag network (usually swag_default)... Then restart swag and wait for it to pull a cert, then restart the container.


    You'd then navigate to service.your-subdomain.duckdns.org


    The swag folder has dozens of service.subdomain.conf.sample files.. (including for the 3 services the OP is talking about).. so all you need to do is copy them and drop the sample extension... you don't even need to adjust them under most cases


    But you're right, if you don't forward 2 ports to swag correctly... you'll never get a cert and none of it will work.

  • OP is using your-subdomain.duckdns.org to access his service and has tried multiple your-subdomains.

    If you got help in the forum and want to give something back to the project click here (omv) or here (scroll down) (plugins) and write up your solution for others.

  • OP is using your-subdomain.duckdns.org to access his service and has tried multiple your-subdomains.

    Well that can be problematic in my experience. Not impossible, just problematic depending on the container. Much easier to do it the way I said.. If that bothers you, purchase a cheap domain (you can get them pretty cheap) and route everything through it.

  • Yes, live can be so easy if you do it right:

    1. set up a dyndns account somwhere
    2. make sure it gets the new IP address if it changes (for me every 24 hours)
    3. get a decent DNS provider
    4. create a wildcard CNAME entry pointing to the dyndns entry
    5. install a battle-tested reverse proxy with automatic creation / renewal of SSL certs (swag, traefik, ...)
    6. make sure you can connect to the admin / status UI of the proxs (does swag have such a thing?)
    7. make your router forward ports 80 and 443 to the proxy
    8. set up your containers
    9. connect your proxy to the containers

    Don't touch it for the next years

    If you got help in the forum and want to give something back to the project click here (omv) or here (scroll down) (plugins) and write up your solution for others.

  • Yes, live can be so easy if you do it right:

    1. set up a dyndns account somwhere
    2. make sure it gets the new IP address if it changes (for me every 24 hours)
    3. get a decent DNS provider
    4. create a wildcard CNAME entry pointing to the dyndns entry
    5. install a battle-tested reverse proxy with automatic creation / renewal of SSL certs (swag, traefik, ...)
    6. make sure you can connect to the admin / status UI of the proxs (does swag have such a thing?)
    7. make your router forward ports 80 and 443 to the proxy
    8. set up your containers
    9. connect your proxy to the containers

    Don't touch it for the next years

    #6 Swag has a park page that lets you verify it is working correctly... all of my services are mapped at service.my-domain.xyz


    If I go to my-domain.xyz, I get the swag park page and it is secured w/ SSL. This lets you know swag is working properly.


  • I've tried to install swag docker, but got these errors in the log. I think everything comes from the fact that I can't open port 443.


  • Go step by step:


    can you access https://marjan-nas.duckdns.org or https://marjan-arr.duckdns.org even if you do not hve secure connections and a browser warning.



    You are trying to get certificates for non-existing domain names.

    NXDOMAIN looking up A for marjan-arr.duckdns.org



    swag works with subdomains, so you would have my-name.duckdns.org as main domain name and nas.my-name.duckdns.org as dns name of your service.


    Did you follow the howto for setting up duckdns and swag?

    If you got help in the forum and want to give something back to the project click here (omv) or here (scroll down) (plugins) and write up your solution for others.

  • Quote

    can you access https://marjan-nas.duckdns.org or https://marjan-arr.duckdns.org even if you do not hve secure connections and a browser warning.

    I can't.


    Quote

    You are trying to get certificates for non-existing domain names.

    NXDOMAIN looking up A for marjan-arr.duckdns.org

    Yeah, I deleted that one in the mean time, ignore that.


    Quote

    No, I followed a youtube tutorial. I will check this one. But the port 443 problem still remains.

  • I think things are moving now! :D I did the wildcard thing, and set it like this:



    And this is the log:



    No errors in the log.

  • If you change a container port away from what is standard as defined in the image documentation, expect problems. There is never a need to do this. Did you?


    Also, you should provide the full names of any images you are using because there can be many variations available.

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 6.x on headless Chenbro NR12000 1U 1x 8m Quad Core E3-1220 3.1GHz 16GB ECC RAM.

  • If it works, redo the setup and get a new duckdns token, or I will take over you domain.

    If you got help in the forum and want to give something back to the project click here (omv) or here (scroll down) (plugins) and write up your solution for others.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!