Raid 5, 3 HDD's, clean degraded

  • you'll have to, and lets hope it works because that is all I can think of

    before i do it:

    I do not understand that the Wiping helps with this problems:


    Code
    root@MEDIASERVER:~# mdadm --readwrite /dev/md127
    mdadm: failed to set writable for /dev/md127: Device or resource busy



    Code
    root@MEDIASERVER:~# mdadm --stop /dev/md127
    mdadm: Cannot get exclusive access to /dev/md127:Perhaps a running process, mounted filesystem or active volume group?

    OMV5: Fractal Design Node 304 - ASRock J3455 ITX - 16GB DDR3 - 400 Watt be quiet! - 32GB SSD - 3x14TB WD Red

  • Because you can add a drive to a degraded even with the raid running as it appears in raid management as clean/degraded. OMV is designed and written so that everything is done from the GUI using the cli is usually a last resort and even then it should be avoided.

    I do not understand that the Wiping helps with this problems

    It doesn't, the fact that you cannot add the drive back to the array from the cli or the gui, it's one of the options to try, the other is to look in omv-extras and look at the section systemrescuecd, this can boot on a one time only and allows to repair/troubleshoot without interacting with OMV. However, this all cli and is not for the faint hearted and should be used as a last resort.


    When you reinstalled and set your server up again I have no idea what may have gone wrong, but something did.


    Using such large drives within an mdadm raid is like running a raid0, and the worst is you have no backup!! I have no problems with users having a raid setup providing they understand how to look after it and resolve any issues. Raid is about availability, so if a drive fails it still functions and that's the only reason.


    So the two choices are yours, wiping the drive may not work, if it doesn't then it's the systemrescuecd option, hopefully that works, if you had a backup a simple start again by wiping the drives and recreating the array after removing smb and shared folders.

    Raid is not a backup! Would you go skydiving without a parachute?


    OMV 5x amd64 running on an HP N54L Microserver

  • okay thanks for your help so far.


    I think I do this:

    I search for some (external) HDD's (maybe some friends can help) and I will do my Backup seperated in different HDD's. This will take several days and it will cost a lot of time and nerves.

    After that I will wipe /dev/sdd. If this does not help I will reinstall OMV again and try to add the drive again. If this does not help aswell, I will wipe all three drives and set a new RAID. Then BackUp goes to the new RAID.


    I will report..

    OMV5: Fractal Design Node 304 - ASRock J3455 ITX - 16GB DDR3 - 400 Watt be quiet! - 32GB SSD - 3x14TB WD Red

  • I backup my RAID.
    So I tried to wipe the drive I got:


    :/

    OMV5: Fractal Design Node 304 - ASRock J3455 ITX - 16GB DDR3 - 400 Watt be quiet! - 32GB SSD - 3x14TB WD Red

  • I pulled the drive out of my NAS and put it to my Desktop PC (have Windows and Linux running there).

    With Windows: can't initialize the drive. Can't format/whipe and when I try to set a New volume I get I/O error (input/output).

    With Linux still the same but SMART says that everything is fine. I am in warranty and I will send it to WesternDigital. Hope that I got a new one. Did not understand why SMART is fine...


    Have to buy a ESD-Bag. I Have read that WD won't accept Warranty without this bag.. So it will take some days

    OMV5: Fractal Design Node 304 - ASRock J3455 ITX - 16GB DDR3 - 400 Watt be quiet! - 32GB SSD - 3x14TB WD Red

  • Get in contact with WD support. They will send a replacement in advance (they block an amount on your credit card in case you do not send the disk back) and you can return the drive in the packaging they send you.

    If you got help in the forum and want to give something back to the project click here and write up your solution for others.

  • oh did not read that :/
    RMA is still not finished. I hope that I get a new one next week.


    Thanks for the hint. Next time (;

    OMV5: Fractal Design Node 304 - ASRock J3455 ITX - 16GB DDR3 - 400 Watt be quiet! - 32GB SSD - 3x14TB WD Red

  • got my hdd back yesterday. Today Recovering the Raid has finished.


    <3:love:<3


    thanks to everyone for help especially geaves.


    /closed

    OMV5: Fractal Design Node 304 - ASRock J3455 ITX - 16GB DDR3 - 400 Watt be quiet! - 32GB SSD - 3x14TB WD Red

  • Darcu

    Added the Label resolved

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!