OMV6 - can SMB1 be enabled

  • Hi,


    Short version - is there any way of enabling SMB1 on OMV6, or do I have to go back to OMV5?


    Long version - I've been running OMV5 for over a year, but had to reinstall, so grabbed the OMV6 image for my Pi. Current version is 6.0.7-1 (Shaitan). All works fine again (shared drives to Windows machines, Plex in docker / Portainer etc.), except my SMB shares can no longer be seen by my RISC OS machines. I'm pretty sure this is because RISC OS only supports SMB1 (yes, I know, insecure... they're working on it...) and I understand that OMV6 has SMB1 disabled by default.


    Apologies if this has been answered elsewhere - I've done some searching and found quite a few posts related to SMB version issues but many involved OMV5 and I couldn't find either a solution or a definitive statement that "this can't be done".


    Thanks,


    David

  • DavidLowe

    Added the Label resolved
  • Watch out, in the future Samba will deprecate this version and eventually Debian will update as well.

    If your client can't really support SMB1, in the future you can evaluate a docker container with an old version just for SMB1, which will have to run on a different port.

    OMV BUILD - MY NAS KILLER - OMV 6.x + omvextrasorg (updated automatically every week)

    NAS Specs: Core i3-8300 - ASRock H370M-ITX/ac - 8GB RAM - Sandisk Ultra Flair 32GB (OMV), 256GB NVME SSD (Docker Apps), Several HDDs (Data) w/ SnapRAID - Fractal Design Node 304 - Be quiet! Pure Power 11 350W


    My all-in-one SnapRAID script!

  • I recently changed from OMV4 to OMV6 when I saw that OMV5 was about to reach end-of-life. I had the same issue with being unable to connect from an XP 'live' CD running Acronis True Image when trying to image my XP machine. Adding the line: server min protocol=NT1 into the SMB/CIFS Extra Options allowed to connect again but, sadly, the peformance is abominable. Every other hardware/software component is exactly the same as it was with OMV4 but now it takes 8-12 times longer to save a partition than it did then. Using FTP also works but it splits archives into 2GB chunks leaving me with lots of separate files.

    Are there any performance tweaks to make imaging work as well as it did before?

    Thanks.

  • the extra option should be servet min protocol=NT1

    If you got help in the forum and want to give something back to the project click here (omv) or here (scroll down) (plugins) and write up your solution for others.

  • hi,

    not sure it is "servet'


    with these parameters,

    Code
    ntlm auth = yes
    min protocol = NT1
    client min protocol = NT1

    it worked yesterday and before, on OMV6 6.0.30-1 (Shaitan). I decide to keep this version, without update this OMV system, because of that:


    But today, on 3 another systems, which have been updated today with about 40 updates (with a lot of samba xxxx items), shares are not seen on 2 kind of players.


    the different available updates :

    Code
    samba-common 2:4.13.13+dfsg-1~deb11u4
    samba-common-bin 2:4.13.13+dfsg-1~deb11u4
    samba-libs 2:4.13.13+dfsg-1~deb11u4
    samba-vfs-modules 2:4.13.13+dfsg-1~deb11u4

    i don't know how to go back with previous versions of that, except reinstall OMV5 (very less issues, compare to omv6).


    edit: i decide to go back to 5.6, and with all sets as usual, all my shares are now seens on different systems.

    Edited once, last by Genna: back to OMV5.6 ().

  • Still can't find omv6’s smb,MY zidoo can't work。。 ;(;(

    - in kodi reset smb setings to default

    - add new network location (or edit your previous suorce)

    - in the server name: put the IP of smb host (not the host name)

    - in the Shared folder: put the smb shared folder name.

    its works with me using omv 6 and Kodi 19 installed on Mi box s (no need to add any extra option parameters in omv smb settings)

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!