SABNZbd downloads folder issue after upgrade

  • I recently upgraded from 4 to 5 and I am seeing some strange behavior out of SABNZbd (and NZBGet, but don't want to muddy the waters here). I have my config stored in /sharedfolders/AppData/SABNzbd and for some reason my downloads are now happening in /sharedfolders/AppData/SABNzbd/Downloads when they should be happening in /sharedfolders/Downloads. In the UI it says that the base folder is "/config" so I guess it isn't surprising. I tried to put in several other paths for the "Downloads" folder but the result was always a download in the /config path.

    I thought I had a workable solution in place by creating a symlink to /sharedfolders/Downloads. This actually worked but the problem I have is that the app is still detecting an incorrect value for the amount of space I have left. This is another thing that is very curious - it detects that I only have about 10 gig of space left when all of my drives have waaaaaay more than that. Could it be detecting the OS drive? I haven't tested it thoroughly but it appears to let me continue to download even after it thinks that I am out of space.  EDIT - it did error out after a few minutes.

    Anyway, here is my folder setup. Any thoughts as to what I could try next would be greatly appreciated.

  • cat /etc/fstab


    ls -al /sharedfolders

    You will need to change the container volumes to the proper place.

  • cat /etc/fstab


    ls -al /sharedfolders

    You will need to change the container volumes to the proper place.

  • OMV4 had your drives mounted under /sharedfolders and the container was built pointing to them.

    OMV5 now, mounts the drive under /srv/dev-disk-by-xxxxxxxx so you need to edit every volume to point to them.

    It's not difficult, if you do it step-by-step.

    First things first, undo any symlink you made pointing to/from /sharedfolders

    Now, make sure that the container doesn't restart everytime:

    • On Portainer, go to containers and click on the container you want to edit (SABNzbd in this case) scroll down and on the Restart Policy, make sure that is set to Unless stopped
    • If it was already, leave it as is. If it was not, change it and click Update

    Now, for safety, stop the container. Click on it's name to open the details:

    • Click on Duplicate/Edit in Actions
    • Scroll down to Advanced container settings and click Volumes
    • Now, change only the --> host lines to point to the proper place.
    • BE EXTRA CAREFULL to point them to the exact place:
      For eg, you have a line with /sharedfolders/Kids_Movies and you change it to /srv/dev-disk-by-label-Movies/Kids_Movies

    REMARK: Don't change the /etc/localtime volume.

    Also, if your container is running as you want, don't change the /sharedfolders/AppData/SABNzbd/config for now.

    That will be after all volumes are guarantied that are working.

    Once your happy with the changes, click Deploy the container

    Start the container and see if the volumes now match what you've changed.

  • Thank you so much! I think the part about the /sharedfolders is what I was missing - I knew something I had changed based on comments from others in here. I didn't realize that they had copied over that folder already for us. Thanks again! I've learned a ton in this process and hope I can pay it forward.

  • muchgooder

    Added the Label resolved

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!