Update bricked my Pi

  • So I've been running a headless NAS with OMV I believe it is ver. 5.6.25

    I am running Docker & Portainer so that most of the services are containerized.

    I found the mentioned Toms hardware article for upgrading to bullseye from buster, deployed it and was okay but updates wouldn't run.

    I let the machine run in that state for about 2 weeks before getting around to troubleshooting it yesterday.

    I had the pam_tally pam_faillock issue mentioned in the attached article and edited & updated the OMV config files to point to pam_faillock & all once again appeared well.

    However updates from the OMV gui failed when all were selected because of various missing dependencies. So I began selecting small groups of updates and started running them. I successfully navigated through 2/3 of the list and came upon some php updates. (I did not take not of which ones ) Upon running the updates all hell broke loose. First the web interface crashed & then on reboot I lost network connectivity so no my pi is bricked.

    In any past troubles I have always still been able to attach via network, with that option gone I need to search the sd card for the source of my troubles but I don't know where to start.

    Can someone give me a starting point?


    Thanks

  • found the mentioned Toms hardware article for upgrading to bullseye from buster, deployed it and was okay but updates wouldn't run

    And now, you need to either ask support there, revert to a previous backup of the SDcard prior to that update or do a fresh install of omv6 and redo all the settings you had.


    If the article you mention is the one to update rpios buster to bullseye, your OMV is completou screwed

  • I know it's not great news but the time spent trying to fix something broken vs. stating fresh with a new install of OMV6 using arm64 will be worthwhile I think.


    I have recently rebuilt my main RPI4 OMV setup and it took about 4hrs in total - including getting 3 dockers setup and running.


    I was in the mood so did the same for my RPI3 OMV setup and used same notes/procedure - took 2 hrs.


    Good news that you have most services running in containers/docker. If you have lots of complex/customised settings in your dockers, then this will be where you have a bit of work to do to get everything back to normal.


    I used brand new SD cards for the new installs so would recommend doing this too.


    Happy to help with clean/new setup on RPI so let us know if you want some help... and sorry about not being able to help fix your current setup.

    OMV 8 (latest) on N100 minipc (16GB) and rpi5 (8GB). OS on SSD/SD. System ext4 on SSD. Data BTRFS on HDDs

  • I haven't given up on my current setup yet. I'm somewhat handcuffed in that I'm 1000 miles away from most of my computer gear including a stinking usb keyboard. I did just lay my hands on a micro to hdmi adapter and found that my system is booting but not networking. I get 2 network errors during bootup:

    1) failed to start openmediavault iptables firewall service

    2) failed to start wait for network to be configured

    So far I've verified that my /etc/netplan/20-openmediavault-eth0.yaml is correct & I tried introducing a new wpa_supplicant.conf file in hopes of gaining wireless access but to no avail. I'm scouring the neighborhood next for a keyboard.

  • The stuff you are doing is way beyond what I can help with. Sorry.


    If you have direct access to the RPI why not just start clean? Is there so much config you will have to recreate or have you made fixing the issue a hobby project? I'm actually interested to know why you want to 'debug/fix' this vs. starting new...

    OMV 8 (latest) on N100 minipc (16GB) and rpi5 (8GB). OS on SSD/SD. System ext4 on SSD. Data BTRFS on HDDs

  • Toms hardware article for upgrading to bullseye from buster, deployed it and was okay but updates wouldn't run

    Raspberry Pi foundation stated in public on https://www.raspberrypi.com/ne…ry-pi-os-debian-bullseye/
    "How do I get it?

    With a major upgrade, we recommend downloading a new image, reinstalling any applications, and moving your data across from your current image. Debian major version upgrades contain a lot of changes, and it is very easy for some small tweak made somewhere in the system to be incompatible with some change you have made, and you can end up with a broken system and a Raspberry Pi that won’t boot. "


    I found myself to be affected by an incompatibility too.

    After some trying to fix, I followed their advice "downloading a new image, reinstalling any applications, and moving your data across from your current image"

    I used the 64bit image, giving many benefits over the 32bit. See https://www.phoronix.com/scan.…aspberrypi-os-64bit&num=1

    omv 6.9.6-2 (Shaitan) on RPi CM4/4GB with 64bit Kernel 6.1.21-v8+

    2x 6TB 3.5'' HDDs (CMR) formatted with ext4 via 2port PCIe SATA card with ASM1061R chipset providing hardware supported RAID1


    omv 6.9.3-1 (Shaitan) on RPi4/4GB with 32bit Kernel 5.10.63 and WittyPi 3 V2 RTC HAT

    2x 3TB 3.5'' HDDs (CMR) formatted with ext4 in Icy Box IB-RD3662-C31 / hardware supported RAID1

    For Read/Write performance of SMB shares hosted on this hardware see forum here

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!