OMV-extras not showing up in GUI

  • KM0201

    Approved the thread.
    • Official Post

    When you installed did you install standard system utilities? It looks like you didn't. You should have installed OpenSSH server and standard system utilities.


    Code
     openmediavault-omvextrasorg depends on dirmngr; however:
      Package dirmngr is not installed.
     openmediavault-omvextrasorg depends on gnupg; however:
      Package gnupg is not installed.

    Try to apt install those two packages, and then try to run the script again (although I'd think the script would pull them.. it does see kinda weird)

    • Official Post

    lthough I'd think the script would pull them

    They are dependencies of the plugin. So, apt should install them unless there is something wrong with the repos. We see this a lot when someone installs from .iso and doesn't have a network connection and no debian repos.

    omv 6.2.0-1 Shaitan | 64 bit | 6.1 proxmox kernel

    plugins :: omvextrasorg 6.1.1 | kvm 6.2.8 | compose 6.6.1 | cputemp 6.1.3 | mergerfs 6.3.5 | zfs 6.0.12


    omv-extras.org plugins source code and issue tracker - github


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

  • Please try ap-get install dirmngr and post he error message. I remember I have seen a conflict, which we were able to resolve, but I do not remember how.

    If you got help in the forum and want to give something back to the project click here (omv) or here (scroll down) (plugins) and write up your solution for others.

  • Hi , KM0201


    From your inference above, I have a feeling that this situation has arisen due to the installation not being able to connect to a mirror upon installation. I am guessing it may not have downloaded the extra files needed . That is if the files are not part of the OMV iso , if they are then I do not understand why they have not installed either.


    sorry had written above then read your message ryecoaaron.


    how do i resolve this issue as installing dirmngr and gnupg and dpkg is not possible with apt-install as a message is returned that these files are part of another package.


    In a previous post detailing my installation problems, I mentioned that the install file would not download the repos from the mirror sites so i had to bypass this in order to complete the installation.


    How do i now manually install the repository info ?


    thanks

  • I get the following message upon apt-install


    root@openmediavault:/etc# apt-get install dirmngr

    Reading package lists... Done

    Building dependency tree... Done

    Reading state information... Done

    Package dirmngr is not available, but is referred to by another package.

    This may mean that the package is missing, has been obsoleted, or

    is only available from another source


    E: Package 'dirmngr' has no installation candidate

    root@openmediavault:/etc#

  • this is my sources.list file ,

    I am assuming this is wrong as there are no active sources here


    # deb cdrom:[Debian GNU/Linux 11 _Bullseye_ - Official Snapshot amd64 LIVE/INSTALL Binary 20211107-12:44]/ bullseye contrib main non-free


    # Line commented out by installer because it failed to verify:

    #deb http://security.debian.org/debian-security bullseye-security main

    # Line commented out by installer because it failed to verify:

    #deb-src http://security.debian.org/debian-security bullseye-security main

  • dirmngr is be part of debian since (at least) stretch and it is in bullseye for sure.


    What system are you on?

    Have you run sudo apt-get update before?


    Post output of cat /etc/apt/sources.list please.

    If you got help in the forum and want to give something back to the project click here (omv) or here (scroll down) (plugins) and write up your solution for others.

  • Fix your sources.list:


    Code
    $ cat /etc/apt/sources.list
    deb http://deb.debian.org/debian bullseye main contrib non-free
    deb http://deb.debian.org/debian bullseye-updates main contrib non-free
    # Uncomment deb-src lines below then 'apt-get update' to enable 'apt-get source'
    # deb-src http://deb.debian.org/debian bullseye main contrib non-free
    # deb-src http://security.debian.org/debian-security bullseye-security main contrib non-free
    # deb-src http://deb.debian.org/debian bullseye-updates main contrib non-free

    If you got help in the forum and want to give something back to the project click here (omv) or here (scroll down) (plugins) and write up your solution for others.

    • Official Post

    Your sources look like that because you did not have a working internet connection on the system when you installled. Zoki's fix should fix the issue. I don't think the omv-extras install script should change the sources.list.

    omv 6.2.0-1 Shaitan | 64 bit | 6.1 proxmox kernel

    plugins :: omvextrasorg 6.1.1 | kvm 6.2.8 | compose 6.6.1 | cputemp 6.1.3 | mergerfs 6.3.5 | zfs 6.0.12


    omv-extras.org plugins source code and issue tracker - github


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

  • macom

    Added the Label resolved

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!