Drive Mount Error - Orange Pi Zero 2

  • Hello everyone, I'm currently trying to run OMV on an Orange Pi Zero 2, first I installed Armbian Bullseye and got OMV 6 to work but I couldn't mount any drives.

    I then read somewhere that, for Arm, Buster is recommended so I went ahead and got Armbian Buster with OMV 5 but I still can't mount any drives, at least OMV 5 gives me a full error report though.

    Both installations were done with the script found here, I also tried both the version with the network setup and the one without.

    I should also point out that I'm indeed using the Orange Pi Zero 2 Armbian build found on the official Armbian website


    So far I've tried "omv-salt stage run prepare" and "omv-aptclean", which were suggested fixes I found on similar looking errors.

    I'm unfamiliar with any of this and OMV has always worked straight out of the box for me before, albeit I never tried it on Arm till now


    Any help is appreciated. Thanks.

  • macom

    Approved the thread.
  • So I've tried reinstalling it twice now, Armbian Bullseye and OMV6 this time, following this tutorial to the T and I still get the same error, this time I managed to catch it happening during the installation as well (see attached image).

    It's followed by another error, this one having something to do with MAC address (see second image).

    If I reboot, the ethernet port stops working and I then have to format the SD card and start all over again.


    What am I doing wrong here?

  • When running the script to install OMV and omv-extras you can skip setting up the network interface

    https://github.com/OpenMediaVa…pt/#to-skip-network-setup


    Another way could be to change the file mentioned in the second screen shot and add the MAC address.

    You can get the MAC address with ip a


    When done configure the network with omv-firstaid. Maybe try this even before editing the file.

  • Running omv-firstaid on eth0 gives me the same error.

    I assumed the problem was with gre0 because that's the file that has the wrong MAC address (/etc/netplan/20-openmediavault-gre0).


    I think the error stems from this part of the installation script:

    Code
    /usr/sbin/omv-rpc -u admin "perfstats" "set" '{"enable":false}'
    /usr/sbin/omv-rpc -u admin "config" "applyChanges" '{ "modules": ["monit","rrdcached","collectd"],"force": true }'
  • Tried the one installation without the network part again, just like I said in the OP.

    Same exact error.

    Can't make any changes on the WebUI without it popping up.


    I have no idea how to proceed.

  • macom

    Added the Label resolved
  • macom

    Added the Label OMV 6.x

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!