"You Need Permission to Perform this Action" Error... again

  • Help! I'm getting a "You need permission to perform this action" error when I try write to a shared folder using Windows 10 File Explorer. I've been working on this for days going through the forum and web searching for an answer but nothing is working for me. I'm a new Linux and OMV user with some experience running Windows getting nowhere. The only thing preventing me from pulling my hair out is that I'm learning so much!

    My use case and environment is I've created an OMV 6.0.27-1 server with all updates applied on a RPi4, 8GB running the 2022-04-04-raspios-bullseye-arm64-lite.img, Debian/Linux 11 image. My media storage attached to the RPi is a WD 8TB 'My Book' drive formatted for EXFAT. This is being accessed by multiple Kodi 19.4 installs running on Amazon FireTV sticks and a Dell 990 Desktop with 16 GB running Win 10 Pro 64b. The FireTV sticks are used for viewing movies and are working fine. The desktop computer sees the shared drives fine and can read files but I can't make any updates. The RPi OS and and OMV were bare metal installs. OMV was installed using the script and procedure in OpenMediaVault-Plugin-Developers / installScript.

    When I first installed this, everything worked fine. I was able to access and view movies through Kodi and I was able to update and manage my movies from my desktop. The next day though I was only able to view movies and read files. I couldn't make any updates to my folders from my desktop. The only thing that I know of that changed was I rebooted my computers. I reinstalled the RPi OS and OMV and again, it worked fine until I rebooted. This is the error I get from Windows File Explorer.

    I've checked all of my permissions in OMV and believe they're correct i.e. user and group permissions set to r/w, SMB services enabled and browseable, SMB Shares set with Guests allowed and Inherit permissions in addition to everything that's already enabled by default.

    Some of the resources I've used to check my configuration and try solutions include:

    I also installed the ResetPerms plugin in OMV and reset my permissions - no luck. Suspecting maybe Windows wasn't presenting the right credentials I used 'net use' to manually log into my shares and confirmed the credentials are being accepted.

    Most of what I've read recommends using EXT4 formatted drives. As mentioned above my drive is formatted using EXFAT. Since I have about 1.5TB of data on it I'm really hoping this isn't the problem and reformatting the drive can be avoided.

    I'll continue to plug but I'm struggling so I'm raising my hand and hoping someone can show me something simple I've overlooked. Thanks in advance.

    Below are some screenshots of my configuration:

    This is my SMB configuration for all shares except for Test_Movies

    This is my OMV configuration for my Test_Movie share. Note Extended attributes and Store DOS attributes are enabled and Extra options are added per "How I solved my file permissions problems (kinda)" forum entry. It didn't help me.

  • Agricola

    Approved the thread.

    I don't know if my problem will translate to anyone else's but just in case it can help others, I was able to resolve my permission problem by reformatting my OMV attached drive to EXT4 and starting over. It was formatted as EXFAT and on both OMV 5 and OMV 6 I was able to r/w from Windows 10 until I restarted OMV. After the OMV restart I could only read from Windows 10.

    There are plenty of hints online that OMV / Linux has permission problems with EXFAT. It may be possible to work around them but I was never able to. My advice would be to not use EXFAT. I hope this helps someone.

  • I'm sure you're right. I wasn't trying to imply this was a problem in OMV or Linux... only that EXFAT doesn't work well with them and should be avoided. It took me many, many hours to get to this understanding so I was just trying to save others some time.

  • I'm having the same problem in Windows, suddenly getting "You Need Permission to Perform this Action". The drives are all EXT4 and have been working for years. I don't know what may have changed. I was copying a movie to a share folder and there was an error saying the file didn't exist. Now every share on OVM has the "You need Permission...." error.

  • Hi, I have the same problem as prann..."You Need Permission to Perform this Action"

    I have a ext4 disk mounted.

    Folder is guest allowed.

    Folders is shared in SMB.

    I`ve reset permission for the folder "Everyone - read/write" via the OMV plugin.

    Anyone can help/suggest?


    How did you solve your problem?

  • Having the same issue as well and googled this to come here and check.

    It may be that I need to log into the server as root instead of my user in windows when I connect to it?

    You'd think with guest permission on and read/write you'd be able to delete files but I have the same issue Win10.

  • I too have a similar problem as the initial post, OMV installed on a raspeberry pi 4 with a exFAT usb external disk.

    I configured everything and it was ok i could read and write to the mapped drive on my Windows 11.

    After reboot i no longer can write in any of my shared folder. Has anyone found a solution other than format the external drive?


Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!