502 bad gateway nginx

  • Where do i check that?

    Do it the same way as you did in #16, but put the result in a code box (button </> in the editor).


    Code
    pi@rpi4:~ $ ls /run
    pi@rpi4:~ $ ls /run/php

    If you got help in the forum and want to give something back to the project click here (omv) or here (scroll down) (plugins) and write up your solution for others.

  • Thanks for the info so far, I will post on my next reboot. Hate to gunk it up now. When you mentioned timing? Is it a PHP service that we can set to delay and thus prevent it from failing?

  • Thanks for the info so far, I will post on my next reboot. Hate to gunk it up now. When you mentioned timing? Is it a PHP service that we can set to delay and thus prevent it from failing?

    Before we try a cure, whe have to find the rout cause

    If you got help in the forum and want to give something back to the project click here (omv) or here (scroll down) (plugins) and write up your solution for others.

  • ok its back after a reboot


    Code
    i@rpi4:~ $ ls /run
    NetworkManager  credentials         dmeventd-server  lvm              pod-filebrowser.pod-id  systemd
    agetty.reload   crond.pid           docker           monit.pid        podman                  thd.socket
    avahi-daemon    crond.reboot        docker.pid       monit.sock       resolvconf              tmpfiles.d
    blkid           crun                docker.sock      motd.dynamic     rngd.pid                udev
    blkmapd.pid     dbus                fsck             mount            rpc_pipefs              user
    chrony          dhcpcd.pid          initctl          netns            samba                   wpa_supplicant
    console-setup   dhcpcd.sock         libpod           network          sshd                    wsdd
    containerd      dhcpcd.unpriv.sock  lock             nginx.pid        sshd.pid
    containers      dmeventd-client     log              omv-engined.pid  sysconfig
    Code
    pi@rpi4:~ $ ls /run/php
    ls: cannot access '/run/php': No such file or directory
  • Are you using folder2ram plugin?

    How are you rebooting the sysem?

    If you got help in the forum and want to give something back to the project click here (omv) or here (scroll down) (plugins) and write up your solution for others.

  • folder2ram copies files to a ram disk on startup and back on shutdown.

    Somehow this does not work for you with the /run/php directory.


    Try creating it and reboot using the ui.

    See if it is there afterwords

    If you got help in the forum and want to give something back to the project click here (omv) or here (scroll down) (plugins) and write up your solution for others.

  • Granted this is the output with it working.

  • Yeah I just tried and uninstalled the flashmemory plugin. Here after the reboot


    Code
    pi@rpi4:~ $ ls -al /run/php
    ls: cannot access '/run/php': No such file or directory
  • This morning I tried it on a different RPI with dietpi instead. Same thing, the instant I install docker, boom DNS goes sideways and php-7.4-fpm failed to start and 502 comes back

  • How did you install docker? Using the Web UI or the script provided by docker?

    If you got help in the forum and want to give something back to the project click here (omv) or here (scroll down) (plugins) and write up your solution for others.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!