Bad read-speed on RaspPi (but good write)

  • Hello everyone,


    Maybe you can help me with my problem, all the other contributions I have found so far in the vastness of the Internet have not been able to solve the problem.


    A small spoiler in advance:

    The text is translated with "https://www.deepl.com/translator", (not sponsored ;)) I think that makes it a bit more understandable than if I try it myself.

    Answers in English are of course no problem.


    I have a Raspberry Pi 4 with OMV installed. A 2.5" HDD is connected. Sharing in the home network via SMB. The entire home network is designed for 1Gbit/s, including switches, cabling and network cards.


    The write speeds also match: From Windows 10 -> RPi-OMV = ~110 MB/s.

    Unfortunately, the read speeds are much lower: From RPi-OMV -> Windows 10 (SSD) = 35-55 MB/s.


    I tried the transfer with different end devices, also under Linux. The values were always nearly the same.


    I don't understand why the transfer from the NAS to Windows/Linux is so much slower than the other way round. Actually, it reads from the NAS HDD, which in my opinion should be faster than writing.


    I will list more technical data below and also what I have already tried.

    I hope I can still get everything together so far...


    ---

    Raspberry Pi 4 Model B Rev 1.5

    Original Manufacturer power supply

    OS: Raspbian lite (64bit)

    Linux version: 5.15.32-v8+

    OMV version: 6.0.21-1 (Shaitan)


    ---

    Storage:

    OS (MicroSD): 64GB SanDisk Extreme

    Data (HDD): 2.5" / USB 3.0 / 4TB / XFS / write cache enabled


    ---

    I have also tested with an external USB 3.0 3.5" HDD with external power supply, here I achieve a read speed of ~60MB/s.

    I have tested all extras in the SMB settings and shares as far as I know, but this has not helped.

    I have attached a screenshot of the share.


    I also ran "$ sudo hdparm -t /dev/sda1". The results are exactly as I would like them to be:


    /dev/sda1:

    Timing buffered disk reads: 356 MB in 3.01 seconds = 118.22 MB/sec.


    I must have forgotten some important info, please let me know.


    Greetings from Germany, I am grateful for any help.

  • contributions I have found so far in the vastness of the Internet have not been able to solve the problem.

    I'd recommend to search specifically in this forum using "site:forum.openmediavault.org".

    There are many similar reports of bad performance with 2.5'' HDDs.

    From my view it could be caused by Shingled magnetic Recording (SMR) and a too small drive hardware cache in combination with "XFS / write cache enabled".

    Is your 2.5'' HDD one of these https://geizhals.eu/?cat=hde7s…ols=959&fcols=8457&sort=p ?


    does performance change when HDD write cache is disabled?

    omv 6.0.28-3 (Shaitan) on RPi CM4/4GB with 64bit Kernel 5.15.32-v8+

    2x 6TB 3.5'' HDDs (CMR) formatted with ext4 via 2port PCIe SATA card with ASM1061R chipset providing hardware supported RAID1


    omv 5.6.21-1 (usul) on RPi4/4GB with 32bit Kernel 5.10.63 and WittyPi 3 V2 RTC HAT

    2x 3TB 3.5'' HDDs (CMR) formatted with ext4 in Icy Box IB-RD3662-C31 / hardware supported RAID1

    For Read/Write performance of SMB shares hosted on this hardware see forum here

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!