Not being to able to run OMV 6 without a graphics unit

  • I've been using my 15-year old hardware (Core 2 Duo E4500) as an OMV server for a few years now (OMV 4, 5, 6). This CPU doesnt have integrated graphics, so I've been using a separate graphics card for installing OMV (Nvidia 8600GT at first, Radeon X300 later on). Whenever the installation via a monitor had been done, I shut the server down, removed the card for power consumption and noise reduction purposes, started it again, and from then on controlled it only over OMV web interface and PuTTy. However with a fresh install of OMV 6 (my first time using it), I don't seem to be able to do it the same way anymore. Whenever I try to start the server with my graphics card out, I'm getting "Software Failure" on web interface, "Network error: connection timed out" on PuTTy and my qbittorrent client is unreachable as well. I have tried doing it multiple times with the same result.


    Am I missing something here or is it intended to work this way in OMV 6?

    This is important to me as if I can't solve the problem, I will have to change my server's hardware configuration. Thank you for your time and I love the new OMV 6 control panel and functionality by the way.

  • Am I missing something here or is it intended to work this way in OMV 6?

    OMV6 is just an application sitting on top of operating system Debian 10, hence a "headless" operation is definitely possible.

    Did you enable access via ssh before removing the graphics card?
    Using ssh/putty checking for errors during boot via dmesg is the recommended approach

    omv 6.0.28-3 (Shaitan) on RPi CM4/4GB with 64bit Kernel 5.15.32-v8+

    2x 6TB 3.5'' HDDs (CMR) formatted with ext4 via 2port PCIe SATA card with ASM1061R chipset providing hardware supported RAID1


    omv 5.6.21-1 (usul) on RPi4/4GB with 32bit Kernel 5.10.63 and WittyPi 3 V2 RTC HAT

    2x 3TB 3.5'' HDDs (CMR) formatted with ext4 in Icy Box IB-RD3662-C31 / hardware supported RAID1

    For Read/Write performance of SMB shares hosted on this hardware see forum here

  • If I remember correctly, there are some boot option to set, so that the kernel does not try to initialize a graphics card, but assumes text mode.

    Google may help if you point it in that direction.

    If you got help in the forum and want to give something back to the project click here (omv) or here (scroll down) (plugins) and write up your solution for others.

  • Did you enable access via ssh before removing the graphics card?

    Yes, I have SSH enabled and whenever I have a graphics card plugged in, OMV's web interface and PuTTy work perfectly fine.

    Using ssh/putty checking for errors during boot via dmesg is the recommended approach

    However, when a GPU is not plugged in, I can't get any remote access to the server whatsoever, so I can't access the terminal as well. Or do you mean I should check some kind of system logs?

  • there are some boot option to set, so that the kernel does not try to initialize a graphics card, but assumes text mode.

    Google may help if you point it in that direction.

    seems the best advice

    omv 6.0.28-3 (Shaitan) on RPi CM4/4GB with 64bit Kernel 5.15.32-v8+

    2x 6TB 3.5'' HDDs (CMR) formatted with ext4 via 2port PCIe SATA card with ASM1061R chipset providing hardware supported RAID1


    omv 5.6.21-1 (usul) on RPi4/4GB with 32bit Kernel 5.10.63 and WittyPi 3 V2 RTC HAT

    2x 3TB 3.5'' HDDs (CMR) formatted with ext4 in Icy Box IB-RD3662-C31 / hardware supported RAID1

    For Read/Write performance of SMB shares hosted on this hardware see forum here

  • Thank you for the suggestions, but this is not the solution of my problem, unfortunately.


    I have edited /etc/default/grub by changing GRUB_CMDLINE_LINUX_DEFAULT from "quiet" to "nomodeset text" and adding the line GRUB_TERMINAL_OUTPUT=console, saved, thoroughly checked the code for typos a few times. Shut down the server, plugged the graphics card out, started again and got the same result. Tried rebooting the server a few times, but it didn't work. Then plugged the card back in and everything works just fine again (and I have reverted the changes now).


    Having read the thread with Google Translate, just to clarify, I think that person's problem is a bit different: while he has trouble starting OMV6 with a monitor plugged out, my problem appears only when a graphics card is plugged out (I don't have a monitor connected to the server at all).

  • Whenever I try to start the server with my graphics card out, I'm getting "Software Failure" on web interface

    This happened to me initially and still does sometimes, try Ctrl + Shift + R the refresh should work

    "Network error: connection timed out" on PuTTy

    Highly likely that the ip address has changed after the reboot, check your router, one way around this might be to set a static ip address on the initial boot (before you shutdown and remove the graphics card). However you need to check your router they all behave differently, as an example mine has a dhcp scope from 65 - 253, so any address before 65 can be used as a static ip, some will allow an option to 'always use the same ip address'. But again you need to set this before the shutdown.

    Raid is not a backup! Would you go skydiving without a parachute?


    OMV 6x amd64 running on an HP N54L Microserver

  • This happened to me initially and still does sometimes, try Ctrl + Shift + R the refresh should work

    Yeah, I had this in mind too and tried Ctrl + Shift + R in my browser as well, but it didn't help.


    Highly likely that the ip address has changed after the reboot, check your router, one way around this might be to set a static ip address on the initial boot (before you shutdown and remove the graphics card). However you need to check your router they all behave differently, as an example mine has a dhcp scope from 65 - 253, so any address before 65 can be used as a static ip, some will allow an option to 'always use the same ip address'. But again you need to set this before the shutdown.

    My OMV server has a static IP on local network, so this is not the solution either, unfortunately. Thank you for your suggestions though.

  • My OMV server has a static IP on local network, so this is not the solution either

    :?: how, as this statement has been on here before, can you ping the ip address of omv

    Raid is not a backup! Would you go skydiving without a parachute?


    OMV 6x amd64 running on an HP N54L Microserver

  • You might try using a "serial console". I have not done it in many years but google can tell you how to do it. I think you should be able to set it up and then remove the card. But you might need to do a "serial console" install. Then restore a backup.

    Good luck

    If you make it idiot proof, somebody will build a better idiot.

  • Put the graphics card in and boot, check the logs from the previous boot (if any).


    If you have systemd's journal set to persistent (should be the default) you can check previous boot logs with journalctl -b -1


    If there's no logs then it's not even booting, which means problem could be with bootloader (grub) or the BIOS that fails to boot without a GPU (though it would be weird if it booted fine before and you didn't change anything in the BIOS settings...). Sometimes BIOS also issues a warning and waits for keyboard press (usually F1) to resume...

  • This could be my problem:


    The question is if there's a way to fix it without a PCI card (I only have PCIe ones).

  • This could be my problem:


    The question is if there's a way to fix it without a PCI card (I only have PCIe ones).

    Interesting!


    I've never come across anything similar, but this would explain why it worked in older versions... probably the device was named eth0, regardless of the pci address and now it's the utterly awkward enp?s?? naming scheme...


    I'm sure there are other ways of working around it... I think there are ways of forcing the old network device names, so you could try that. For example try the grub options mentioned here: https://unix.stackexchange.com…rk-interfaces-in-debian-9


    There might be other ways... because on my desktop debian machine, my ethernet device is called eno1 and then ip says it's also known as enp0s31f6


    Output of ip a:


    Code
    2: eno1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether 1c:69:7a:6f:1d:f5 brd ff:ff:ff:ff:ff:ff
    altname enp0s31f6


    Not sure where this eno1 comes from though...


    I also remember in some old computer running debian, after a release upgrade it maintained the eth0 name (this might have been an upgrade from debian 9 to 10 though, not debian 11), while on a clean install of the same debian version (again might have been debian 10) it assigned the same device the enp?s?? name.


    Yet another possibility, if you have an USB ethernet dongle, you can connect it and it should still have the same name after removing the GPU, so you could then connect to OMV through the USB ethernet and reconfigure the internal ethernet from there...


    One other could be removing the OMV OS disk from the computer, connect to another computer and edit the configs and change the network device name (you'd need to know the name of the device after removing the GPU, but that should possible by reading the logs in the disk).

  • This assumes your OMV is actually booting. Set OMV to dhcp. Set up a static reservation for the mac address on your router or dhcp server. This should give you the address you set there. No matter what the device name is.


    To see if it is booting watch the hard drive activity light with and without the card. It should be about the same for both.

    If you make it idiot proof, somebody will build a better idiot.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!