No PubKey Login

  • Hello,


    My OMV seems inconsistent, but I'm not sure if I should really blame it.


    From machine 1 I can login via public key authentication.

    From machine 2 I can only login via password authentication.

    The above is the same for ssh via the terminal or sftp via Nemo.

    User is the same.

    Machine one runs on Bodhi

    Machine 2 runs on Sparky


    sshd_config allows both, PW and public key as I wanted this "backdoor" still open in case I lose a key file, not ideal, I know.


    On machine 2 I generated the key and ssh-copy-id ..ed it over to the OMV however with option -f (forced mode).

    Without the forced mode, it returns:


    I named the key of machine to ...-1 to avoid potential douplicate issues.

    What explains this different behaviour for one and the same user?

    Some content might be slightly modified to mask personal settings- just to keep the sharks away, you never know :)

  • what is the -n option supposed to do here? And the port does not need to be quoted.

    And it is user@machine or machine only without @

    If you got help in the forum and want to give something back to the project click here (omv) or here (scroll down) (plugins) and write up your solution for others.

  • Ahh yes.... [where is the had bang smiley?].


    Code
    ssh-copy-id -f -p '123' -i ~/.ssh/id_ed25519-A.pub USER@192.177.3.22

    ...did it after all.

    -n was left over from a dry-run attempt.


    This is actually a non-thread now, nobody would learn anything from this (apart from that too long hours or hot weather get your brain scrambled).


    admin: feel free to delete, I'll mark it as solved.


    Thanks Zoki once again!

    Some content might be slightly modified to mask personal settings- just to keep the sharks away, you never know :)

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!