Removing mergerfs caused chaos

  • Hi guys. I need some help with mergerfs. Since I moved from my OMV5 system on a RPi3 to my current Intel x86 based system with OMV6, I had a lot of problem. But now this is the biggest: I had an SSD with the system and 2 HDDs (4+2TB). I wanted to handle them as one drive so installed mergerfs. But there was some strange issue and I think casue is mergerfs for that. So I just deleted the merged drive and removed mergerfs plugin. Here started the problems. Before I did that, I didn't remove shared folders and didn't change the absolute path. So now I cannot reach them from Windows. I cannot even update the system because I got error when clicking the pipe at configuration update. (attached the error message. At Storage/Shared folder I cannot even edit the shared folders, got error message here also. Access control list and delete buttons are grey.

    I attached my fstab and fstab.bak file. Which is strange it shows some error on my system SSD.

    So could you please give me some hint how can I solve this issue? Should I set back the mergerfs first or what should I do how can I make my drive and system working again? I really really appreciate for your support becuase honestly I am not a Linux expert, I am not familiar with commands so I was growing up with Windows. Previously I just installed OMV5 on Pi and worked without any trouble.

    fstab.bak.txt

    fstab.txt

    OMV_failure_editing_folder.txt

    OMV_failure_sys_update.txt

  • So I just deleted the merged drive and removed mergerfs plugin.

    How did you delete the merged drive? I would think it is not possible from the GUI, if there are still shared folders pointing at that pool.


    You could try to fix the database of omv (config.xml) manually. But I would suggest to do a fresh install.



    But there was some strange issue and I think casue is mergerfs for that.

    As we don't know what these issues caused, there might be a bigger problem. So maybe first thing to do is to check if the data are still on the two drives and check them with SMART and fsck.

  • Just selected the merged pool and push the delete button. It didn't show any warning or something like that.

    Yeah, maybe it will be the easiest if I do a clean install.

    My storage is ok, I have my contents. For example I can play via Plex. I surprised on that. The smaller drive was not in used since I installed OMV6, I formatted it and it was empty since that. But now it looks like it broke because smart shows bed sector faults on it. I will take it out from the NAS and check with Hdsentinel on my PC.

  • When you check it on, the pool will be mounted by fstab. That is, how the plugin worked in OMV5. Now ryecoaaron changed it and the pool will be mounted by systemd instead. That is the preferred method.

    So the preferred method is not to check in fstab? Is that correct?

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!