I am trying out OMV 6 (current version is 6.0.24 at time of writing this). I searched for information about disk encryption in OMV, but I mostly found explanations and questions about encrypting storage volumes. When it comes to encrypting the OS volume, that is, the HDD/SSD that contains the OMV rootfs, I only found: https://github.com/gandalfb/op…ault-full-disk-encryption - and these steps seem rather elaborate, the outcome uncertain (see the notes about Docker mount errors that can happen if OS disk encryption is done differently for example). I see a risk of instability and (potentially silent) errors here that I am unwilling to take for a NAS machine that runs 24/7 and houses my data.
Therefore, it seems to me that at this stage, encrypting the OS volume is simply not possible in OMV without spending considerable amount of time studying the inner workings of OMV to ensure that any manual attempts at accomplishing this task do not exhibit unwanted side effects.
But this is then a pity, since encrypting the OS disk has the nice advantage that any risk of information leakage (log files stored in a non-volatile mount point for example) is dealt with - all of the data is encrypted (or resides in volatile storage). Without encryption, it becomes necessary to check each and every service, daemon etc. for what files it creates and where these are stored.
Thoughts? Opinions? Experiences?