Getting "500-Internal Server Error" on login screen

  • I just upgraded to OMV 6, and when I try to log in, I get the error 500 - Internal Server Error. It never proceeds past the login screen, and I get the error whether or not I enter correct or incorrect login information.

  • I got a similar message for refresh_apt_database, omvextrasbaserepo, deb [arch=amd64] https://download.docker.com/linux/debian buster stable, and refresh_database_apt.


    At this point, I no longer get the error, instead it hangs and then times out on login.

    • Official Post

    E: The repository 'http://security.debian.org/debian-security buster-security Release' does not have a Release file.

    This is still buster.


    Are you sure you upgraded to OMV6/bullseye?


    check the output of

    cat /etc/debian_version

    dpkg -l | grep openmediavault

    • Official Post

    I just upgraded to OMV 6,

    How did you upgrade?


    The output says you are still on Buster / Debian 10, but that you have OMV6 installed.


    Try to run omv-release-upgrad, but might be the script is already removed.


    If you get "command not found" replace buster by bullseye in the sources lists.

    Code
    sed -i 's/buster/bullseye/g' /etc/apt/sources.list
    sed -i 's/buster/bullseye/g' /etc/apt/sources.list.d/*.list
    sed -i 's#/debian-security bullseye/updates# bullseye-security#g' /etc/apt/sources.list

    Then run apt update.

    If there are errors post here.

    If not run apt upgrade

  • I upgraded using omv-release-upgrade, but that script is no longer there, as you suggested.


    Running apt update, I got these errors:


    Code
    Err:16 http://deb.debian.org/debian-security bullseye/updates Release
    404  Not Found [IP: 199.232.162.132 80]
    Hit:17 http://ppa.launchpad.net/jcfp/sab-addons/ubuntu focal InRelease
    Hit:18 http://packages.openmediavault.org/public shaitan InRelease
    Hit:19 https://packages.sury.org/php bullseye InRelease
    Reading package lists... Done
    E: The repository 'http://deb.debian.org/debian-security bullseye/updates Release' does not have a Release file.
    N: Updating from such a repository can't be done securely, and is therefore disabled by default.
    N: See apt-secure(8) manpage for repository creation and user configuration details.
  • Yes, I got those errors after that. Here is my sources.list file.


    Code
    deb http://deb.debian.org/debian bullseye main
    deb-src http://deb.debian.org/debian bullseye main
    
    
    deb http://deb.debian.org/debian-security/ bullseye/updates main
    deb-src http://deb.debian.org/debian-security/ bullseye/updates main
    
    
    deb http://deb.debian.org/debian bullseye-updates main
    deb-src http://deb.debian.org/debian bullseye-updates main
  • cat /etc/apt/sources.list.d/*.list


    • Official Post

    Why do you have these sources?


    Code
    -rw-r--r-- 1 root root 126 Oct  9 15:50 /etc/apt/sources.list.d/jcfp-ubuntu-nobetas-focal.list
    -rw-r--r-- 1 root root 132 Oct  9 15:50 /etc/apt/sources.list.d/jcfp-ubuntu-sab-addons-focal.list
    -rw-r--r-- 1 root root 511 Oct  9 15:50 /etc/apt/sources.list.d/mysql.list
    -rw-r--r-- 1 root root  49 Oct  9 15:50 /etc/apt/sources.list.d/php.list
    • Official Post

    Why do you have these sources?

    Because docker is hard... lol

    omv 6.0.46-5 Shaitan | 64 bit | 5.19 proxmox kernel | plugins :: omvextrasorg 6.1.1 | kvm 6.2.5 | mergerfs 6.3.3 | zfs 6.0.12
    omv-extras.org plugins source code and issue tracker - github


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

    • Official Post

    comment these lines in sources.list by adding a # in front

    deb http://deb.debian.org/debian-security/ bullseye/updates main

    deb-src http://deb.debian.org/debian-security/ bullseye/updates main

    you have the correct lines in


    /etc/apt/sources.list.d/openmediavault-os-security.list

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!