Container errors after moving docker location

  • I recently had a disk failure that required me to move the location of Docker to another drive. I have my config files in a different "AppData" folder so at worst I have had to execute the docker compose files again. I am having some errors with a few of the containers. While trying to re-create Docker I copied over the existing Docker installation. I suspect that the "overlay2" folder had issues as I eventually had to exclude it from the copy as it was erroring out.

    The errors seem to be somewhat similar. For example, Murmur is erroring out:

    resulted in this:


    ERROR: for Murmur Cannot create container for service murmur: open /srv/dev-disk-by-label-Backup/Docker/overlay2/59aa666136ad027d5ef4de282616fa10fffe4d06a3d451f5267995dcdd3241c2/link: no such file or directory

    ERROR: for murmur Cannot create container for service murmur: open /srv/dev-disk-by-label-Backup/Docker/overlay2/59aa666136ad027d5ef4de282616fa10fffe4d06a3d451f5267995dcdd3241c2/link: no such file or directory

    ERROR: Encountered errors while bringing up the project.

    Mariadb (which also worked fine before) had a similar issue:


    Building with native build. Learn about native build in Compose here:

    ERROR: stat /srv/dev-disk-by-label-Backup/Docker/overlay2/36ae00f9c685ad098084c6107bab35d563fb2da27e626c60bd4a540acfd7c6c0: no such file or directory

  • Please read and Guides

    You need to specify a good persisten PATH to store config

    and use apropiate PUID & GUID.

    This is a working murmur.yaml file for my path

    and this is my enviroment.env file:


    and how to use this info?

    easy, go to portainer stack, and use " + add stack":

    then copy paste murmur.yaml file

    them add the apropiate ( yours) enviroments variables (your PATH to store config, and your PUID & GUID to run docker:

    finally deploy te stack.

    and see if murmur is running:

    update: my-net is my network for all my dockers, create it on:

  • As always, thank you so much for taking the time to post this. This is a fantastic resource and I look forward to improving the way that I am creating these containers. I can definitely clean some things up.

    So I corrected the file path issue - thank you for that, I had completely missed it.

    But that didn't fix my issue. The issue seems to be related to the fact that I copied over some of the docker environment from a failing hard drive. Other containers had similar issues - I renamed the container name and things went smoothly. I am still having this issue. Any idea what might be causing it?

  • thank you again for the help! Issuing a prune solved the problem. I had been refraining from doing it until I had all of the other containers running. Maybe that's a bit conservative but I am still learning in this area.

  • muchgooder

    Added the Label resolved

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!