Permissions Problems on MacOs

  • I am on a Raspberry Pi 4 8GB. Suddenly I get this error when trying to copy to my CIFS shared folder:


    The operation can’t be completed because you don’t have permission to access some of the items.


    If I copy a folder of files it seems to copy the folder but nothing inside it. I get the same error trying to delete the folder that copied up as well.


    I tried updating the ACLs on the shared folder with the old use and creating a new user as well it just keeps happening. At this point I think my permissions need to be rest but I can't seem to find out how.


    Any ideas?



    Lorenzo

  • So to update if anyone cares is that whenever I touch a folder it gets a line in the cifs diag section under locked files like the one below:


    26662 1000 DENY_NONE 0x100081 RDONLY NONE /srv/dev-disk-by-uuid-a197476d-fecb-4b49-bc75-3eceefa0f050/Lorenzo Media Wed Nov 16 11:22:05 2022


    The pid 26662 is my user login that is doing the browsing.



  • Thanks I’ll,try it again Didn’t seem to work for me before. I have no problem copying with the command line so,I’m pretty sure it’s not a permissions problem. I downgraded to buster and omv 5 to alleviate for now.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!