docker not working since omv-upgrade

  • Here is the solution to disable apparmor on the system and it worked on my test system (not harmful since apparmor package is not installed):

    Code
    sudo mkdir -p /etc/default/grub.d
    echo 'GRUB_CMDLINE_LINUX_DEFAULT="$GRUB_CMDLINE_LINUX_DEFAULT apparmor=0"' | sudo tee /etc/default/grub.d/apparmor.cfg
    sudo update-grub
    sudo reboot

    Taken from: https://wiki.debian.org/AppArmor/HowToUse#Disable_AppArmor

    This solution was effective for me as well. One point, of course, on my system there was no need to do the mkdir command as the grub.d directory already exists ...


    Thanks ryecoaaron

  • I've had the same problem on my Odroid HC2, I fixed it by downgrading the docker-ce and docker-ce-cli packages, then restarting the docker service:


    Code
    sudo apt install docker-ce-cli=5:20.10.23~3-0~debian-bullseye
    sudo apt install docker-ce=5:20.10.23~3-0~debian-bullseye
    sudo service docker restart

    OMV 6 on Raspberry Pi 3/4/5, Odroid C2/HC2 and three cobbled together x64 boxes running Snapraid.

  • I've had the same problem on my Odroid HC2, I fixed it by downgrading the docker-ce and docker-ce-cli packages, then restarting the docker service:


    Code
    sudo apt install docker-ce-cli=5:20.10.23~3-0~debian-bullseye
    sudo apt install docker-ce=5:20.10.23~3-0~debian-bullseye
    sudo service docker restart

    I also confirm this works. Had to re-install Portainer though. It's now back on the default ports (9000 and 8000).

  • I've had the same problem on my Odroid HC2, I fixed it by downgrading the docker-ce and docker-ce-cli packages, then restarting the docker service:


    Code
    sudo apt install docker-ce-cli=5:20.10.23~3-0~debian-bullseye
    sudo apt install docker-ce=5:20.10.23~3-0~debian-bullseye
    sudo service docker restart

    Probably the best workaround - reverting the change - until everything is fully understood. Thanks.

  • WIth armbian, since there's no grub, adding to armbianEnv.txt


    extraargs=apparmor=0


    and rebooting worked on my Rock64 without having to downgrade. Would imaging should also work on Odroid HC-2, XU4, etc.


    Updating grub worked on my other OMV systems with x86 processors.

  • Here is the solution to disable apparmor on the system and it worked on my test system (not harmful since apparmor package is not installed):

    Code
    sudo mkdir -p /etc/default/grub.d
    echo 'GRUB_CMDLINE_LINUX_DEFAULT="$GRUB_CMDLINE_LINUX_DEFAULT apparmor=0"' | sudo tee /etc/default/grub.d/apparmor.cfg
    sudo update-grub
    sudo reboot

    Taken from: https://wiki.debian.org/AppArmor/HowToUse#Disable_AppArmor

    Thank you for this "fix". I was really worried when restarting docker and trying a reboot didn't cause my containers to restart, especially when I tried docker restart on portainer.


    Will this become a pull request for OpenMediaVault and be published in a patch release? Or is AppArmor something that is used by some in the OpenMediaVault community?

    OMV 6
    Jonsbo N1 NAS

    5 - 4 TB Seagate Iron Wolf NAS HDDs

    1 - 120 GB Kingston SSD

    32 GB G.Skill Ripjaws V Series DDR4 3200

    Intel Core i3-12100

    Asrock H610M-ITX/AC

    SilverStone ECS07 5-Port SATA Gen3 6Gbps Non-RAID M.2 PCIe Storage Expansion Card

    Corsair SF600 80+ Gold Certified Fully Modular PSU

    • Official Post

    One point, of course, on my system there was no need to do the mkdir command as the grub.d directory already exists ...

    The -p flag means it only creates the directories if they don't exist. So, there is nothing wrong with run the mkdir command in any case.

    omv 7.4.0-1 sandworm | 64 bit | 6.8 proxmox kernel

    plugins :: omvextrasorg 7.0 | kvm 7.0.14 | compose 7.2.1 | k8s 7.2.0-1 | cputemp 7.0.2 | mergerfs 7.0.5 | scripts 7.0.8


    omv-extras.org plugins source code and issue tracker - github - changelogs


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

    • Official Post

    Probably the best workaround - reverting the change - until everything is fully understood. Thanks.

    Why is it the best? Staying on the same package is only a short term solution. You will have to apt-mark hold docker-ce to prevent it from being upgrade.

    omv 7.4.0-1 sandworm | 64 bit | 6.8 proxmox kernel

    plugins :: omvextrasorg 7.0 | kvm 7.0.14 | compose 7.2.1 | k8s 7.2.0-1 | cputemp 7.0.2 | mergerfs 7.0.5 | scripts 7.0.8


    omv-extras.org plugins source code and issue tracker - github - changelogs


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

    • Official Post

    Will this become a pull request for OpenMediaVault and be published in a patch release? Or is AppArmor something that is used by some in the OpenMediaVault community?

    This isn't an OMV core problem. omv-extras is installing docker and I will look at adding it but the different solutions for non-amd64 systems will be a pain. apparmor is not installed by default on OMV. If someone uses it, they can install docker without omv-extras.

    omv 7.4.0-1 sandworm | 64 bit | 6.8 proxmox kernel

    plugins :: omvextrasorg 7.0 | kvm 7.0.14 | compose 7.2.1 | k8s 7.2.0-1 | cputemp 7.0.2 | mergerfs 7.0.5 | scripts 7.0.8


    omv-extras.org plugins source code and issue tracker - github - changelogs


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

  • Why is it the best? Staying on the same package is only a short term solution. You will have to apt-mark hold docker-ce to prevent it from being upgrade.

    I have the same issues today and was thinking this is the best solution also. I understand that AppArmor is initiated on Grub and rolling back will only work till next update, but it seams disabling AppArmor still leaves portainer inoperable?

  • I have the same issues today and was thinking this is the best solution also. I understand that AppArmor is initiated on Grub and rolling back will only work till next update, but it seams disabling AppArmor still leaves portainer inoperable?

    in my case i have portainer fully functional and apparmor disabled like ryecoaaron has suggested

  • Not sure why some people are having issues with Portainer. Works fine for me with the apparmor grub change. I agree that rolling back to the older version of docker isn't the best fix as you'll eventually have to update, and since it's a change that came directly from Docker, I wouldn't expect it to magically work later without making some form of change to apparmor.


    Considering Portainer is a relatively simple reinstall, I would try that over rolling back to an older Docker. If it still fails, try reinstalling the Portainer container from the CLI to see what could be causing the issue.

    • Official Post

    I'm sure the portainer container just need to be recreated which is what omv-extras is doing when you "uninstall" it and then reinstall it. I should just convert it to compose on the backend.

    omv 7.4.0-1 sandworm | 64 bit | 6.8 proxmox kernel

    plugins :: omvextrasorg 7.0 | kvm 7.0.14 | compose 7.2.1 | k8s 7.2.0-1 | cputemp 7.0.2 | mergerfs 7.0.5 | scripts 7.0.8


    omv-extras.org plugins source code and issue tracker - github - changelogs


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

  • Looks like docker FINALLY released the release notes for 23.


    Docker Engine 23.0 release notes


    "Known issues

    Some Debian users have reported issues with containers failing to start after upgrading to the 23.0 version. The error message indicates that the issue is due to a missing apparmor_parser dependency:"


    "The workaround to this issue is to install the apparmor-utils package manually:


    Code
    apt-get install apparmor-utils



    • Official Post

    The workaround to this issue is to install the apparmor-utils package manually

    The problem is that it installs apparmor. Not a big deal for regular Debian users since apparmor is installed by default.

    omv 7.4.0-1 sandworm | 64 bit | 6.8 proxmox kernel

    plugins :: omvextrasorg 7.0 | kvm 7.0.14 | compose 7.2.1 | k8s 7.2.0-1 | cputemp 7.0.2 | mergerfs 7.0.5 | scripts 7.0.8


    omv-extras.org plugins source code and issue tracker - github - changelogs


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!