Receiving hourly email from cron about snapshot cleanup

  • Hello all,

    Since upgrading to openmediavault-6.4.0-1, I have begun to receive an hourly email like the following:


    Subject: [] Cron <root@omv6> cd / && run-parts --report /etc/cron.hourly

    Body: run-parts: /etc/cron.hourly/openmediavault-cleanup_sf_snapshots exited with return code 1

    It seems that the "openmediavault-cleanup_sf_snapshots" script calls the command "omv-sfsnapadm cleanup". In the OMV GUI, if I navigate to "Storage > Shared Folders > All Snapshots > Settings", I see that the "Enable automatic snapshot clean up" setting is disabled (unchecked). However, in this case, "omv-sfsnapadm cleanup" returns with exit code 1, which causes cron to report an error. For example:

    $ sudo omv-sfsnapadm -v cleanup
    Cleaning up snapshots from shared folders has been disabled.
    $ echo "$?"

    It seems like maybe this should, instead, return 0? Or perhaps the wrapper script should catch this output (instead of redirecting to /dev/null) and avoid sending an email?

    It seems like there are 2 possible workarounds to avoid the cron error emails:

    1. In the OMV GUI Snapshot settings, enable the automatic snapshot cleanup checkbox
    2. Edit the script "/usr/sbin/omv-sfsnapadm", line 190, to "sys.exit(0)" since it's not really an error to have this option disabled

    Has anyone else bumped into this? How have you resolved it? Maybe I should take this opportunity to learn more about Shared Folder Snapshots. Thanks in advance!

  • The same problem I have.... immediately after upgrading to openmediavault-6.4.0-1,.....

  • votdev

    Added the Label resolved
  • I am getting this issues on version 6.4.3-1 (Shaitan) running on kernal: Linux 5.19.17-2-pve and amd64

    full error:

    I did remove a number of shares from the server when they died and it started after that.

    omv 6.0.46-5 Shaitan | 64 bit | 5.19 proxmox kernel

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!