Cannot mount existing file system from external USB HDD anymore

  • I'm experiencing a weird problem with an external USB HDD, which I use for backups:

    I realized some days ago, that the backup tasks broke down. OMV flagged the backup filesystem on my USB HDD as "missing". I've detached the USB HDD from the server and reattached it again. It apparently had issues. At least, I was not able to mount it, neither through OMV, nor manually via the CLI. Using fsck I was able to repair the filesystem. At least I was able to mount it manually again afterwards. Scanning through the directories the data looked ok. At this stage I unmounted the drive again and tried to reintegrate it into the OMV environment. I started removing all references to the old mount point, in rsync in the SMB shares. I finally removed the old mount point itself and applied all changes. When I look into the discs I see the device (/dev/sdj) as "unmounted". If I go to filesystems I select /dev/sdj1 and use the "play" button to mount an existing filesystem. A window pops up asking me about the filesystem to mount. However, the drop-down list to select the (existing) filesystem is empty.

    I assume that the HDD crashed at some stage. As I can mount it manually, I don't think it is broken though. I'm not sure whether this an inconsistency in the configuration. In any case, any ideas to mount the HDD or to debug the problem further, will be appreciated.

  • I'm sure it is a configuration inconsistency now: The USB HDD is actually mounted under /srv/dev-by-uuid-5909.... A corrsponding fstab entry exists as well. Could be a relic. The filesystem does still not appear in the GUI under storage/filesystems though. I also cannot create a shared folder referencing the filesystem. For OMV it is invisible.

    When I unmount the filesystem manually and try to mount it via the GUI, I get an error that external quotas can no longer be used on ext4 filesystems. This is driving me mad!

    Anybody who can help with this?

  • I could not fix the issue but found a workaround.

    First, some more observations as I found that others ran into similar issues, and as I believe others probably will in the future.

    The problem was an inconsistency between the OMV configuration and the underlying debian linux configuration. I finally realized that the USB drive was completely full. I assume that this was the root cause leading to the "missing filesystem" error in the first place, although I believe that this should not happen on a NAS system.

    I freed up some space on the drive thinking this may help with mounting the existing filesystem. It didn't. Following recommendations from other threads, I tried to restore consistency by running omv-salt deploy run fstab. This removed the problematic mount point entry from the fstab (but did not unmount the drive). In any case, whenever I rebooted the server, the rogue fstab entry reappeared. I don't know whether this is some kind of "automount" feature for (USB) drives, but I could not get rid of it.

    As I was stuck, I finally decided to remove the affected disk from the OMV system-configuration completely. In order to achieve that, I did the following:

    • Per CLI: omv-salt deploy run fstab to create a "consistent" fstab.
    • I then manually unmounted the affected USB drive and removed the empty /srv/dev-by-uuid-5950.. directory
    • Back into the OMV GUI: Storage / Disks: Here I simply wiped the USB drive.
    • Under Storage / Disks I created a new ext4 filesystem on the drive and, yes, the corresponding device was finally visible to OMV
    • The filesystem was still not mounted automatically after the creation process, but I could mount it using the "play/arrow" button on that page.
    • Finally, the application of the configuration changes also succeeded without quota or other errors.

    I'm now running rsync to create a new backup. Of course you cannot do this, if you require the data on the affected drive, or you have to copy it somewhere else first. For what it's worth...

    I'll keep the thread open as unresolved, as I wasn't able to fix the actual problem.

  • Hi m4tt0

    I have the same problem right now.

    I did not use my nas for a few weeks and realised today, that i can't access my files anymore.

    When setting it up everything was fine and running.

    When I check my data system is says its referenced and online but not mounted. The tic is missing. Sometimes it says volume is missing.

    I did the complete procedure in the omv ui and used the raspberry just to install omv.

    I did notice a strange sound from my hdd. it sounded like a spindown. But there is nothing put in the settings from my side. I think it startet after an update.

    I set everything up 2 month ago. The HDD is in an ICYBOX and new.

    Any idea what i can try?

  • Hi Chiller8891,

    I'd first check whether the HDD is actually still ok. Can you attach it to another computer and mount the drive there? Can you see files on that drive? And can you ensure that the drive is not 100% full, which may have led to the problems I were facing?

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!