SnapRaid + mergerfs fails

  • Hi everybody

    i´m too stupid! Could you help me, pls?


    I´ve a new installed OMV 7.x @Fujitsu machine - the system is on a sata-ssd (micron) and there are two 12GB sata-hdd´s. One of them should work as data-drive, one parity.

    I try to install and config SnapRaid / mergerfs because of possible plug-in more data-hdd´s later.


    - the drives are shown into the drives section; formatted as ext4

    - i go to SnapRaid-Plugin -> create new array "Datenpool" -> confirm the configuration

    - than drives: 1 data drive with directory and data - 1 drive with parity -> confirm

    - mergerfs: new (+) -> name:Datenpool .... choose my data drive .... shared folders no at that time ..... the mergerfs Datenpool is shown as:



    I´ll confirm the config and -> look @attachment file, please - it´s too long for posting directly as code.

    :(


    I do not understand what happens?!

    Could you help me, please?

    :) :love:

    • Official Post

    If you only have one data drive you don't need mergerfs. mergerfs is used to create a data pool by joining several hard drives.

    Simply configure SnapRaid with the single data drive and the single parity drive.

  • I know that - but the system is for a friend and he has no computer skills.

    He should be able to simply connect new drives without changing the whole config - only add the new drive(s) to the pool - ready.

    That´s why i´ld create a pool and so the whole shares will based on the pool - even not only on one single data drive.

  • You could do like this for an easy to grow mergerfs pool that once initially configured needs no changes - just add more disks.


    Create a directory in the root of your single data drive named Datenpool. The name is arbitrary, use whatever you want for the directory name.


    Define your mergerfs pool like this:


    Name: Datenpool

    Path: /srv/dev-disk-by-uuid-*/Datenpool


    The pool will only include files in the Datenpool directory of each disk, not any other files or directories in the root of the drives.


    To add a new disk to the pool in the future, just format the disk and create the Datenpool directory in its root. No need to change the the mergerfs configuration as mergerfs will automatically pick up new drives so long as they have a Datenpool directory in their root.


    Good luck.

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 7.x on headless Chenbro NR12000 1U 1x 8m Quad Core E3-1220 3.1GHz 32GB ECC RAM.

  • What you are using for the pool path is not what I suggested. You will have to type that in by hand.

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 7.x on headless Chenbro NR12000 1U 1x 8m Quad Core E3-1220 3.1GHz 32GB ECC RAM.

  • I have two pools I created this way in the past. But for some reason this no longer works.


    All I get is a new but broken link in the /srv/mergerfs directory. I have no explanation; perhaps one of the devs can help?

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 7.x on headless Chenbro NR12000 1U 1x 8m Quad Core E3-1220 3.1GHz 32GB ECC RAM.

  • OK, found the problem. Change the typed in path to:


    Path: /srv/dev-disk-by*/Datenpool

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 7.x on headless Chenbro NR12000 1U 1x 8m Quad Core E3-1220 3.1GHz 32GB ECC RAM.

  • Works for me. What you are seeing is focussing on quotas. Have you made any changes there?

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 7.x on headless Chenbro NR12000 1U 1x 8m Quad Core E3-1220 3.1GHz 32GB ECC RAM.

  • no ..... i only made a normal installation, set-up a user (sambashare group member), installed a few extensions - most not configured yet) - the next step should set-up the drives.....

    :(


    Before that i made a full-backup from extern .... should i restore that and make a new try?

  • Before that i made a full-backup from extern ....

    I don't know what this means.


    You are probably getting close to abandoning this install and starting over.

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 7.x on headless Chenbro NR12000 1U 1x 8m Quad Core E3-1220 3.1GHz 32GB ECC RAM.

  • I suppose you can try restoring your backup. It may tell you if your backup strategy is actually working, or not. But those error files that are loaded with quota problems tell me something else is broken. Did you format your hard drives in OMV or are they imported from an old setup?


    I don't use the SnapRAID plugin so I can't help you with that other than to say you must have at least one data drive (other than the OS drive), one parity drive, and you should specify both of these drives for content.


    There is no relationship between SnapRAID and mergerfs. They are not dependencies of each other and they do not interoperate with each other. They are two completely different things that have nothing to do with each other. Having said that, naming your SnapRAID Array and your mergerfs Pool with the exact same names shouldn't hurt anything, but it isn't going to help anything either. And doing so may be confusing to you and to others when you ask for help. I suggest not doing this.

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 7.x on headless Chenbro NR12000 1U 1x 8m Quad Core E3-1220 3.1GHz 32GB ECC RAM.

    • Official Post

    It is a quota issue. This thread has the same solution - Error When Apply NFS Configuration

    omv 7.4.2-2 sandworm | 64 bit | 6.8 proxmox kernel

    plugins :: omvextrasorg 7.0 | kvm 7.0.14 | compose 7.2.1 | k8s 7.2.0-1 | cputemp 7.0.2 | mergerfs 7.0.5 | scripts 7.0.8


    omv-extras.org plugins source code and issue tracker - github - changelogs


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

    • Official Post

    I´ll check that later. I´ve to read that first and my English is´nt the best.

    To sum it up, using the mounteditor plugin to remove quota options and then the command to remove the aquota files are the things you should do.

    omv 7.4.2-2 sandworm | 64 bit | 6.8 proxmox kernel

    plugins :: omvextrasorg 7.0 | kvm 7.0.14 | compose 7.2.1 | k8s 7.2.0-1 | cputemp 7.0.2 | mergerfs 7.0.5 | scripts 7.0.8


    omv-extras.org plugins source code and issue tracker - github - changelogs


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!