Emby Docker error "version` is obsolete"

  • God morning, i have deploy Emby Docker and it´s running on my OMV 7 Nas but when start into log show next error "

    ="2024-07-11T09:38:16+02:00" level=warning msg="/srv/dev-disk-by-uuid-713ef34c-19ea-474f-b170-8516cb4d21b7/Dockers/Emby/Emby.yml: `version` is obsolete". I have deployed last version Emby Docker and i have copy from Emby web "Emby Server for Docker" section.



    Best regards and sorry fo my basic enghish i am learning :)

  • Thanks. This is docker code yhan running in my OMV now...


    version: "2.3"

    services:

    emby:

    image: emby/embyserver

    container_name: embyserver

    # runtime: nvidia # Expose NVIDIA GPUs

    # network_mode: host # Enable DLNA and Wake-on-Lan

    environment:

    - UID=996 # The UID to run emby as (default: 2)

    - GID=100 # The GID to run emby as (default 2)

    - GIDLIST=100 # A comma-separated list of additional GIDs to run emby as (default: 2)

    volumes:

    - /srv/dev-disk-by-uuid-713ef34c-19ea-474f-b170-8516cb4d21b7/Dockers/Emby:/config # Configuration directory

    - /srv/dev-disk-by-uuid-b4c3069e-bf17-42ed-b46f-fd09f5f7373e/BIBLIOTECA/Series:/Series # Media directory

    - /srv/dev-disk-by-uuid-b4c3069e-bf17-42ed-b46f-fd09f5f7373e/BIBLIOTECA/Peliculas:/Peliculas # Media directory

    ports:

    - 8096:8096 # HTTP port

    - 8920:8920 # HTTPS port


    restart: unless-stopped



    ...then , i must delete line wih version?



    Regards

  • Other dubt. I wisht installNextcloud in my OMV 7. I see 1 exanmple in compose section of my OMV to instal Nextcloud


    services:

    nextcloud:

    image: lscr.io/linuxserver/nextcloud:latest

    container_name: nextcloud

    environment:

    - PUID=1000

    - PGID=1000

    - TZ=Etc/UTC

    volumes:

    - CHANGE_TO_COMPOSE_DATA_PATH/nextcloud/config:/config

    - CHANGE_TO_COMPOSE_DATA_PATH/nextcloud/data:/data

    ports:

    - 443:443

    restart: unless-stopped


    But I have seen that there is another extensive month code:


    version: '2'


    volumes:

    nextcloud:

    db:


    services:

    db:

    image: mariadb:10.6

    restart: always

    command: --transaction-isolation=READ-COMMITTED --log-bin=binlog --binlog-format=ROW

    volumes:

    - db:/var/lib/mysql

    environment:

    - MYSQL_ROOT_PASSWORD=

    - MYSQL_PASSWORD=

    - MYSQL_DATABASE=nextcloud

    - MYSQL_USER=nextcloud


    app:

    image: nextcloud

    restart: always

    ports:

    - 8080:80

    links:

    - db

    volumes:

    - nextcloud:/var/www/html

    environment:

    - MYSQL_PASSWORD=

    - MYSQL_DATABASE=nextcloud

    - MYSQL_USER=nextcloud

    - MYSQL_HOST=db


    ....and I don't know if which of the 2 codes is better for domestic use. I am all dubts..



    Best regards

  • delete version: "2.3"


    so emby.yml file star with services:

    • New
    • Official Post

    ....and I don't know if which of the 2 codes is better for domestic use. I am all dubts..

    I suggest you read this document. https://wiki.omv-extras.org/doku.php?id=omv7:docker_in_omv

    It will help you clear up many doubts.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!